Bug 505927 - Dual battery
Dual battery
Status: CLOSED DUPLICATE of bug 511411
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 14:41 EDT by Luke Sheldrick
Modified: 2009-07-28 07:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 07:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Sheldrick 2009-06-14 14:41:15 EDT
Description of problem:
On my Dell D630, I have the standard battery as well as the Media bay battery. 

Just being using it on F11, and noticed a slight annoyance. 

The battery status is only for one battery, whilst the other shows as being connected to the mains (when it isn't).

When the first battery is about to be depleted, lots of the 'Battery about to run out' prompts are presented to the user, until that battery fully empties, and then a 'Battery full' message is presented and normality restored. 

So there are two faults really.

1) the user is alerts, in error. So much as yes the first battery is about to deplete, btu there is another fully charged, so maybe the messages should say "Battery A almost run out, Battery B 100%" or similar

2) the second battery (not being used at the time) is shown as being plugged in, when it isn't.

Version-Release number of selected component (if applicable):

Installed Packages
DeviceKit-power.i586               008-1.fc11          installed                
gnome-power-manager.i586           2.26.2-1.fc11       installed                

Not sure if devicekit comes into play but version included in case.
Comment 1 Luke Sheldrick 2009-06-14 14:43:26 EDT
Battery details;

[root@zoidberg ~]# cat /proc/acpi/battery/BAT0/info 
present:                 yes
design capacity:         5200 mAh
last full capacity:      4046 mAh
battery technology:      rechargeable
design voltage:          11100 mV
design capacity warning: 520 mAh
design capacity low:     157 mAh
capacity granularity 1:  52 mAh
capacity granularity 2:  52 mAh
model number:            DELL KP4288
serial number:           12177
battery type:            LION
OEM info:                Sony
[root@zoidberg ~]# cat /proc/acpi/battery/BAT0/state 
present:                 yes
capacity state:          ok
charging state:          charged
present rate:            1 mA
remaining capacity:      3999 mAh
present voltage:         12435 mV
[root@zoidberg ~]# cat /proc/acpi/battery/BAT1/info 
present:                 yes
design capacity:         4324 mAh
last full capacity:      4324 mAh
battery technology:      rechargeable
design voltage:          11100 mV
design capacity warning: 432 mAh
design capacity low:     131 mAh
capacity granularity 1:  43 mAh
capacity granularity 2:  43 mAh
model number:            DELL 0007P8
serial number:           446
battery type:            LiP
OEM info:                Sanyo
[root@zoidberg ~]# cat /proc/acpi/battery/BAT1/state 
present:                 yes
capacity state:          ok
charging state:          charged
present rate:            1 mA
remaining capacity:      431 mAh
present voltage:         11215 mV
Comment 2 Luke Sheldrick 2009-06-14 14:45:49 EDT
Actually that last copy was erroneous, the last BAT1/state was taking about 5 minutes later, so the current info is

[root@zoidberg ~]# cat /proc/acpi/battery/BAT0/state 
present:                 yes
capacity state:          ok
charging state:          discharging
present rate:            2668 mA
remaining capacity:      3432 mAh
present voltage:         11508 mV
[root@zoidberg ~]# cat /proc/acpi/battery/BAT1/state 
present:                 yes
capacity state:          ok
charging state:          charged
present rate:            1 mA
remaining capacity:      431 mAh
present voltage:         11215 mV

Now using the second battery..
Comment 3 Richard Hughes 2009-06-14 15:08:27 EDT
I'm working on this now.
Comment 4 Richard Hughes 2009-07-28 07:02:48 EDT

*** This bug has been marked as a duplicate of bug 511411 ***

Note You need to log in before you can comment on or make changes to this bug.