Bug 505941 - cupsd hanged while using webui
cupsd hanged while using webui
Status: CLOSED DUPLICATE of bug 505692
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 16:29 EDT by Michal Hlavinka
Modified: 2009-06-17 08:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 08:04:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2009-06-14 16:29:59 EDT
Description of problem:
cups webui doesn't work, cupsd hangs eating 100 % cpu

Version-Release number of selected component (if applicable):
$ rpm -qa | grep cups
cups-1.4-0.b2.18.fc11.x86_64
bluez-cups-4.37-2.fc11.x86_64
gutenprint-cups-5.2.3-5.fc11.x86_64
cups-libs-1.4-0.b2.18.fc11.x86_64
hal-cups-utils-0.6.19-2.fc11.x86_64
cups-debuginfo-1.4-0.b2.18.fc11.x86_64


How reproducible:
always

Steps to Reproduce:
1. open https://localhost:631/
2. click administration
3. click add printer
4. enter root with password (or just don't enter any password - hit cancel)
  
Actual results:
cups webui not responding, cupsd hanged taking 100% cpu

Expected results:
working cups webui

Additional info:
(gdb) bt full
#0  0x00007f5cd30037a3 in __epoll_wait_nocancel () from /lib64/libc.so.6
No symbol table info available.
#1  0x00007f5cd60ca41c in cupsdDoSelect (timeout=1) at select.c:481
        i = <value optimized out>
        event = <value optimized out>
        nfds = <value optimized out>
        fdptr = <value optimized out>
        pfd = <value optimized out>
        count = <value optimized out>
#2  0x00007f5cd60a3e8c in main (argc=<value optimized out>, argv=<value optimized out>) at main.c:836
        i = 1514
        opt = <value optimized out>
        fg = <value optimized out>
        fds = 2
        con = <value optimized out>
        job = 0x0
        lis = <value optimized out>
        current_time = <value optimized out>
        browse_time = 1245009466
        senddoc_time = 1245009465
        expire_time = 1245009466
        report_time = 0
        event_time = 1245008314
        timeout = 1
        current_time = <value optimized out>
        browse_time = 1245009466
        senddoc_time = 1245009465
        expire_time = 1245009466
        report_time = 0
        event_time = 1245008314
        timeout = 1
        limit = {rlim_cur = 1024, rlim_max = 1024}
        action = {__sigaction_handler = {sa_handler = 0x7f5cd60a3360 <sigterm_handler>, sa_sigaction = 0x7f5cd60a3360 <sigterm_handler>},
          sa_mask = {__val = {81920, 0 <repeats 15 times>}}, sa_flags = 0, sa_restorer = 0}
        netif_time = 1245009465
        failmode = FAIL_IGNORE

-----------------------------------------

(gdb) bt
#0  0x00007f5cd30037a3 in __epoll_wait_nocancel () from /lib64/libc.so.6
#1  0x00007f5cd60ca41c in cupsdDoSelect (timeout=1) at select.c:481
#2  0x00007f5cd60a3e8c in main (argc=<value optimized out>, argv=<value optimized out>) at main.c:836
Comment 1 Tim Waugh 2009-06-17 08:04:08 EDT
This looks like the same problem as bug #505692.

*** This bug has been marked as a duplicate of bug 505692 ***

Note You need to log in before you can comment on or make changes to this bug.