Bug 505968 - Warzone 2100 game screen not visable
Warzone 2100 game screen not visable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: warzone2100 (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Karol Trzcionka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 21:12 EDT by Steven Drinnan
Modified: 2010-01-20 04:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-20 04:20:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of game (702.87 KB, image/png)
2009-06-14 21:12 EDT, Steven Drinnan
no flags Details
Screenshot of game (70.26 KB, image/png)
2009-07-03 17:36 EDT, Martin A. Boegelund
no flags Details
Debug output from Warzone 2100 (152.46 KB, text/plain)
2009-07-07 15:09 EDT, Martin A. Boegelund
no flags Details

  None (edit)
Description Steven Drinnan 2009-06-14 21:12:31 EDT
Created attachment 347876 [details]
Screen shot of game

Description of problem:

I installed the game from the repos and when I started it all good. But when I tried to play a game you can not see any background. Thus making it unplayable. 

In F10 it showed OK but some elements were not drawn correctly. 
In F11 beta the game worked OK.

Version-Release number of selected component (if applicable):
Warzone 2100 - Version 2.1.2

How reproducible:
Always Just start the game try to play


Steps to Reproduce:
1.
2.
3.
  
Actual results:

See screen shot


Expected results:

Game plays as normal


Additional info:

Intel 965 video shared memory
Ram 4gb (showing 3.8 the other for video)
Intel Core Duo T5670 1.8
Default F11 live cd install

Same results with compiz enabled
Comment 1 Martin A. Boegelund 2009-07-03 17:32:35 EDT
I can confirm this bug.
Warzone2100 worked OK in F9 and F10. After upgrading to F11 (using the preupgrade method), game screen is all black, and I can't see my units. I can only see their status bars when I select them and have them in focus - so I'm not just looking at the "Fog of war".

I've tried to fiddle with various video and graphics setting, but nothing helped - everything remained black.
Comment 2 Martin A. Boegelund 2009-07-03 17:36:20 EDT
Created attachment 350460 [details]
Screenshot of game

An in-game screenshot. Everything is black, but you can see the green status bar of one of my units, so it's not just a picture of the "fog of war".
Comment 3 Martin A. Boegelund 2009-07-06 06:50:54 EDT
This bug is reported against x86_64 Linux, but my system is x86 (2 GHz Intel Celeron).

I've tried to enable and disable Compiz, toggle "Windowed" and "Full screen" game modes, and remove/rename .warzone2100-2.1 directory, things that are suggested remedies to this problem on other bug reporting forums. Nothing helped.
Comment 4 Martin A. Boegelund 2009-07-07 15:09:35 EDT
Created attachment 350851 [details]
Debug output from Warzone 2100

I ran the game with the "--debug=all" and "--debugfile ~/wz2100.debug" command line options. Please find my debug file as an attachment.
Comment 5 Martin A. Boegelund 2009-07-08 04:13:49 EDT
I found this on the Warzone 2100 development forum
http://forums.wz2100.net/viewtopic.php?f=6&t=3227&p=31232#p31232
"No textures? Black/corrupted screens? Crashes to desktop?

Postby Buginator ยป 24 Jun 2009, 06:39
What do all these have in common?

In almost all cases, this is the fault of crappy video drivers.

Here is a small article for the intel crowd: http://mjg59.livejournal.com/111853.html

Intel, and S3/Via integrated gfx chipsets have pretty poor OpenGL support."

So it looks like you, Steven, could be hit by your Intel video cards poor OpenGL support.

My video card is based on the ATI Radeon 9200 SE chip. I'll try the propriety driver for my card, and maybe an alternative card, and post the results here.
Comment 6 Martin A. Boegelund 2009-08-10 05:25:16 EDT
I tried to get the propriety driver for my ATI card to work, but failed.

I then bought a videocard with an NVIDEA GPU, and installed the propriety driver for it. This solved the problem for me.

The open drivers that you can get in Fedora distro-packages (nv and nouveau) also worked (no black screen) but the game was too slow to play - I guess lack of acceleration support in the drivers was the problem.
Comment 7 Steven Drinnan 2009-08-18 22:59:58 EDT
Looks like there is a deeper problem than just blaming the poor quality of my intel graphics card. As you said you could not get ATI to work either. And like I said it was working to some degree in F10 and working perfectly in F11 Beta. So there must of been some changes to make this failure.

Any progress?


Steven Drinnan
Comment 8 Steven Drinnan 2009-09-02 20:27:27 EDT
I had a similar problem with H-Craft (Demo) - changing mipmapping off fixed the problem, this could be the issue.

BTW i can use openarena gravity and other 3d games without a problem, windows I do know has crappy opengl support but linux is pretty good.

Steven
Comment 9 Steven Drinnan 2009-11-04 20:19:28 EST
Resolved, after update this issue has been fixed.

Note You need to log in before you can comment on or make changes to this bug.