Bug 506033 - Crash in ktorrent during basic operation
Crash in ktorrent during basic operation
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ktorrent (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Roland Wolters
Fedora Extras Quality Assurance
:
Depends On: 506032
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 07:13 EDT by Michael Schwendt
Modified: 2009-09-07 22:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-07 22:45:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2009-06-15 07:13:55 EDT
Tracker-ticket until it's known which component causes ktorrent to crash.

Assuming it's qca2: bug 506032
Comment 1 Rex Dieter 2009-06-15 08:42:50 EDT
Please test new pending update:
https://admin.fedoraproject.org/updates/ktorrent-3.2.2-2.fc10
Comment 2 Michael Schwendt 2009-06-15 08:58:12 EDT
Need a test-case first. :) What part of downloading a torrent involves qca2 based hash generation? Any downloaded piece? Or only specific data parts? Can I expect further crashes while continueing to download the F11 DVD that has caused the two crashes very early? Since then, ktorrent-3.2.1-1.fc10.i386 with qca2-2.0.2-1.fc10.i386 and qt-4.5.1-11.fc10.i386 has not crashed again.

(and, of course, it would be helpful if the pending updates were pushed, as there are quite a lot kde deps and new debuginfo pkgs needed)
Comment 3 Roland Wolters 2009-06-15 15:16:47 EDT
QCA can be used to generate hashes - so it might be that qca is used for the hash generation in ktorrent, which means it is used all the time.

I hope that the pending updates are pushed to testing asap. @Rex, any idea why it takes that long?
Comment 4 Rex Dieter 2009-06-15 15:28:15 EDT
the latest push was initiated yesterday sometime, and it's still running.  cross your fingers.
Comment 5 Steven M. Parrish 2009-07-05 08:26:50 EDT
Is this still an issue?

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Michael Schwendt 2009-07-08 06:53:40 EDT
Honestly, I cannot tell. I've upgraded to F11 meanwhile and can't retry ktorrent without a test-case, and restarting a F11 DVD download is no fun. The backtrace is in the linked bug 506032.
Comment 7 Steven M. Parrish 2009-09-07 22:45:06 EDT
Ok going to close this for the moment.  Please feel free to reopen if the problem returns.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.