Bug 506048 - trac does not work with subversion due to sqlite configuration problem - SubversionException: 'Could not configure SQLite'
trac does not work with subversion due to sqlite configuration problem - Subv...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 07:58 EDT by Felix Schwarz
Modified: 2009-08-10 17:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.6.4-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 17:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2009-06-15 07:58:06 EDT
Fedora 11 ships Subversion 1.6.1 which fails if sqlite was already initialized by another module in this process. This is the case if trac uses sqlite the database connector (default) with a subversion repository (default).

The whole problem (with an easy testcase) is described in this Gentoo bug:
http://bugs.gentoo.org/show_bug.cgi?id=264241

The problem was acknowledged upstream and fixed in Subversion 1.6.2:
http://subversion.tigris.org/issues/show_bug.cgi?id=3387

Can you upgrade Subversion in F11 to 1.6.2 or at least backport the fix (r37185 in Subversion's repo) for F11? If we leave it like this, another popular Fedora package (trac) remains broken in its default configuration.

cc'ing Fedora trac maintainers as they are likely to get these bug reports (hope you don't mind the spam).
Comment 1 Fedora Update System 2009-06-18 09:52:07 EDT
subversion-1.6.2-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/subversion-1.6.2-3.fc11
Comment 2 Fedora Update System 2009-06-19 09:42:19 EDT
subversion-1.6.2-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update subversion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6758
Comment 3 Fedora Update System 2009-08-09 06:11:43 EDT
subversion-1.6.4-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/subversion-1.6.4-2.fc11
Comment 4 Fedora Update System 2009-08-10 17:53:35 EDT
subversion-1.6.4-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.