Bug 506049 - problem with rport if load-balancing service over one machine
problem with rport if load-balancing service over one machine
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: piranha (Show other bugs)
4
All Linux
high Severity high
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On: 500909
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 08:02 EDT by Marek Grac
Modified: 2016-04-26 21:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: piranha-0.8.3.1-6
Doc Type: Bug Fix
Doc Text:
Previously, the pulse daemon failed when users added a real port in the graphical user interface of piranha. This was due to problems with rport if piranha tried to load-balance over one machine. With this update, specifying a real port in lvs.cf no longer causes pulse to fail.
Story Points: ---
Clone Of: 500909
Environment:
Last Closed: 2011-02-16 11:21:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Marek Grac 2009-06-26 07:13:03 EDT
Patch from RHEL 5 can be used
Comment 2 Werner Maes 2009-11-17 08:51:31 EST
I still experience this problem with latest redhat piranha packages: piranha-0.8.4-13.el5.i686.rpm.

Although the output from ps aux |grep nanny shows that nanny uses port 808
/usr/sbin/nanny -c -h ip1 -V ip2 -p 8080 -s GET / HTTP/1.1\r\n\r\n -x HTTP/1.1 -t 3 --fos

in reality tcpdump -i any port 8080 gives no output. nanny uses the standard port 80 instead which is not according to our configuration.

installing the previous piranha rpm 0.8.4-11.el5.i686.rpm FIXES the problem.
Comment 3 Marek Grac 2009-12-22 04:01:54 EST
Werner:

please open new bz (in RHEL5 project) and add lvs.cf
Comment 4 Werner Maes 2009-12-22 08:53:07 EST
what exactly do you mean with RHEL5 project bugzilla?
Comment 5 Marek Grac 2009-12-22 09:13:14 EST
This is bugzilla for Red Hat Cluster Suite 4. 
You have problem in version 5, cluster is part of Red Hat Enterprise Linux 5. 

Create new bug in RHEL 5 / piranha.
Comment 6 Werner Maes 2009-12-22 09:37:39 EST
I hope this is correct:

https://bugzilla.redhat.com/show_bug.cgi?id=549738
Comment 7 Werner Maes 2009-12-22 11:07:11 EST
I hope this is correct:

https://bugzilla.redhat.com/show_bug.cgi?id=549738
Comment 8 Marek Grac 2009-12-22 11:15:11 EST
Yes, it is - thanks
Comment 11 Florian Nadge 2011-01-03 09:27:50 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the pulse daemon failed when users added a real port in the graphical user interface of piranha. This was due to problems with rport if piranha tried to load-balance over one machine. With this update, specifying a real port in lvs.cf no longer causes pulse to fail.
Comment 12 errata-xmlrpc 2011-02-16 11:21:26 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0272.html

Note You need to log in before you can comment on or make changes to this bug.