Bug 506051 - "Delete messages more than *number* days old" doesn't work well.
"Delete messages more than *number* days old" doesn't work well.
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: thunderbird (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 08:07 EDT by Qunfang Zhang
Modified: 2009-06-22 18:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 18:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 479207 None None None Never

  None (edit)
Description Qunfang Zhang 2009-06-15 08:07:20 EDT
Description of problem:
"Delete messages more than *number* days old"  doesn't work well.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.22-2.el5_3

How reproducible:


Steps to Reproduce:
1.Go to Edit->Account Settings->Offline & Disk Space
2.check option "Delete messages more than *number* days old", set $NUMBER to 1.
3.click "OK"
4.choose any folder of this account, go to Edit->Folder Properties, in Tab "Retention Policy"
  
Actual results:
After step 4,the option "Delete messages more than 1 days old" is not checked. 

Expected results:
The option "Delete messages more than 1 days old" is checked.

Additional info:
Comment 1 Matěj Cepl 2009-06-16 11:36:53 EDT
(In reply to comment #0)
> Actual results:
> After step 4,the option "Delete messages more than 1 days old" is not checked. 
> 
> Expected results:
> The option "Delete messages more than 1 days old" is checked.

Well, much more interesting than whether some checkbox is checked or not, is whether more than 1 day old messages are actually deleted. Are they?
Comment 2 Qunfang Zhang 2009-06-16 21:49:16 EDT
> Well, much more interesting than whether some checkbox is checked or not, is
> whether more than 1 day old messages are actually deleted. Are they?  

In fact, more than 1 day old messages are not actually deleted. But I'm not sure whether my operation is wrong, because I find some existed bug is similar to this bug, for example #472157.
Comment 3 Matěj Cepl 2009-06-22 18:45:43 EDT
We filed this bug in the upstream database (http://bugzilla.mozilla.org/show_bug.cgi?id=479207) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.