This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 506057 - iscsid generates lots of AVC messages
iscsid generates lots of AVC messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.3
ia64 Linux
low Severity medium
: rc
: ---
Assigned To: Daniel Walsh
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 08:38 EDT by michal novacek
Modified: 2012-10-15 10:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 04:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Part of the audit.log (44.18 KB, application/octet-stream)
2009-06-15 08:38 EDT, michal novacek
no flags Details
This is avc messages log from the failed test in rhts. (150 bytes, text/plain)
2009-06-16 04:23 EDT, michal novacek
no flags Details

  None (edit)
Description michal novacek 2009-06-15 08:38:58 EDT
Created attachment 347928 [details]
Part of the audit.log

Description of problem:

I encountered this problem when testing new release of iscsid. There is a bunch of AVC messages generated when I do simple login/logout to scsi target


Version-Release number of selected component (if applicable): iscsi-initiator-6.2.0.871-0.5.el5

How reproducible: always

Steps to Reproduce:
1. install iscsi-initiator-6.2.0.871-0.5.el5 from brew
2. use iscsiadm to log to torget
  
Actual results:
Bunch of AVC denial messages generated

Expected results:
No AVC messages generated.

Additional info:
Comment 1 Daniel Walsh 2009-06-15 15:25:15 EDT
You attached the /var/log/messages not /var/log/audit/audit.log

Are you testing with the latest selinux-policy-targeted?
Comment 2 michal novacek 2009-06-16 04:23:36 EDT
Created attachment 348057 [details]
This is avc messages log from the failed test in rhts.
Comment 3 michal novacek 2009-06-16 04:29:15 EDT
(In reply to comment #1)
> Are you testing with the latest selinux-policy-targeted?  

I'm using non-updated fresh install of rhel5-server-u3 on rhts which comes with selinux-policy-targeted-2.4.6-203.el5.
Comment 4 Daniel Walsh 2009-06-16 09:48:54 EDT
Ok this looks like this is still present in the 5.4 policy



Fixed in selinux-policy-2.4.6-247
Comment 5 michal novacek 2009-06-17 12:24:28 EDT
Thanks. Is it available as rpm somewhere?
Comment 11 errata-xmlrpc 2009-09-02 04:00:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1242.html

Note You need to log in before you can comment on or make changes to this bug.