Bug 506073 - Installing GRUB fails on disk different than installation
Installing GRUB fails on disk different than installation
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
anaconda_trace_hash:ef91c969fe0b9340b...
:
: 528394 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 09:34 EDT by Maurice Pijpers
Modified: 2010-02-23 14:02 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-12.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 14:02:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (240.46 KB, text/plain)
2009-06-15 09:34 EDT, Maurice Pijpers
no flags Details
Kickstart file (3.84 KB, application/octet-stream)
2009-10-12 10:11 EDT, Cole Robinson
no flags Details
The correct kickstart this time (3.79 KB, text/plain)
2009-10-12 10:14 EDT, Cole Robinson
no flags Details

  None (edit)
Description Maurice Pijpers 2009-06-15 09:34:38 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/booty/x86.py", line 371, in grubbyDiskName
    return "hd%d" % self.drivelist.index(name)
  File "/usr/lib/anaconda/booty/x86.py", line 376, in grubbyPartitionName
    return "(%s,%d)" % (self.grubbyDiskName(name), partNum)
  File "/usr/lib/anaconda/booty/x86.py", line 180, in writeGrub
    f.write('#          root %s\n' % self.grubbyPartitionName(bootDevs[0]))
  File "/usr/lib/anaconda/booty/x86.py", line 534, in write
    justConfig | (not self.useGrubVal))
  File "/usr/lib/anaconda/bootloader.py", line 204, in writeBootloader
    justConfigFile)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1339, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1360, in handleRenderCallback
    self.currentWindow.renderCallback()
ValueError: list.index(x): x not in list
Comment 1 Maurice Pijpers 2009-06-15 09:34:48 EDT
Created attachment 347936 [details]
Attached traceback automatically from anaconda.
Comment 2 David Cantrell 2009-09-07 18:39:20 EDT
Can you attach the kickstart file you used to perform this installation?
Comment 3 Radek Vykydal 2009-09-08 04:04:06 EDT
David,
just fyi, we have been working on grub stuff for mdraid 1 boot partitions (not this case, but the same codepath probably) with Hans, but the patches are not in yet as I was waiting for some more feedback.
https://www.redhat.com/archives/anaconda-devel-list/2009-July/msg00236.html
If you want, you can reassign the bug to me.
Comment 4 Chris Lumens 2009-10-12 09:45:34 EDT
*** Bug 528394 has been marked as a duplicate of this bug. ***
Comment 5 Cole Robinson 2009-10-12 10:11:00 EDT
Created attachment 364463 [details]
Kickstart file

Sorry for the dup, bugzilla search doesn't like me.
Comment 6 Cole Robinson 2009-10-12 10:14:17 EDT
Created attachment 364466 [details]
The correct kickstart this time
Comment 7 Radek Vykydal 2009-10-12 11:42:15 EDT
Cole, thanks for the kickstart, I've prepared updates file with patch that should fix the bug. If you want to test it you can add anaconda boot option updates=http://rvykydal.fedorapeople.org/updates.driveorder.img.
Comment 8 Cole Robinson 2009-10-12 11:52:37 EDT
Awesome! I'll give it a spin tonight.
Comment 9 Cole Robinson 2009-10-12 19:57:55 EDT
Dropped the updates file in images/, everything seemed to work fine! Thanks.

Please consider this fix for F12.
Comment 10 Radek Vykydal 2009-10-13 10:02:44 EDT
The fix should appear in anaconda-12.38-1.
Comment 11 Bug Zapper 2009-11-16 05:12:38 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.