Bug 506082 - Some hotkeys are not accurate
Some hotkeys are not accurate
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: thunderbird (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 09:59 EDT by Mark Xie
Modified: 2009-06-16 16:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 16:41:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 498725 None None None Never

  None (edit)
Description Mark Xie 2009-06-15 09:59:04 EDT
Description of problem:
Some hotkeys are not accurate, when pressed, they will open the wrong dialogue box or wrong window.

Version-Release number of selected component (if applicable):
RHEL5 Client - thunderbird-2.0.0.22-2.el5_3 - i386 (en_US)

How reproducible:
Allways

Issue 1, Compose Window -- Set Format --Discontinue Link

Steps to Reproduce:
1.   'Ctrl + N' to open a new message window and write some characters or any other things else.
2.    Choose some characters and Insert some links('Insert > Link'), and then put the cursor to the link
3.    Press 'Ctrl + Shift + K'
  
Actual results:
A spelling check box popup when 'Ctrl+Shift+K' pressed

Expected results:
It's expect to open the Discontent link by press 'Ctrl + Shift + K'

Additional info:

====================
Issue 2, Compose Window -- Insert Rows to a exist Table

Steps to Reproduce:
1.   'Ctrl + N' to open a new message window and Insert a table('Insert > Table')
2.    Put the cursor into any cell of this table.
3.    Insert a row in this table by keyboard operation,("Format  > Table > Insert > Row Above ' )
  
Actual results:
if do all these operates by keyboard, "Format  > Table > Insert > Row Above ' will not insert a line above the current line, but set the focus to the mail-address area.

Expected results:
It should be insert a new row correct.

Additional info:

====================
Issue 3, Compose Window -- Select elements from current table

Steps to Reproduce:
1.   'Ctrl + N' to open a new message window and Insert a table('Insert > Table')
2.    Put the cursor into any cell of this table.
3.    Select this table by keyboard operation,("Format  > Table > Select > Table ' )
  
Actual results:
Operates by keyboard, it will select the whole table, but it will change the focus to the "Subject" area.  uper-case "S" is for the table, and little case "s" is for the email "Subject" area.

Expected results:
It should still keep the focus in the content area.

Additional info:

====================
Issue 4, Compose Window -- Delete elements from current table

Steps to Reproduce:
1.   'Ctrl + N' to open a new message window and Insert a table('Insert > Table')
2.    Put the cursor into any cell of this table.
3.    Delete a row in this table by keyboard operation,("Format  > Table > Delete > Row(s) ' )
  
Actual results:
Operates by keyboard, when deleting row, only upper case "R" will work. Others works ok.

Expected results:
If it's a upper case 'R', it's better specify it by some lable.

Additional info:

====================
Issue 5, Compose Window -- Split cell

Steps to Reproduce:
1.   'Ctrl + N' to open a new message window and Insert a table('Insert > Table')
2.    Put the cursor into any cell of this table.
3.    Split a row in this table by keyboard operation,("Format  > Table > Split Cell ' )
  
Actual results:
Only joined cells can split 

Expected results:
sometimes, the user will expect split normal cell.

Additional info:

====================
Issue 6, Compose Window -- Create table from selection

Steps to Reproduce:
1.   'Ctrl + N' to open a new message window and Insert a table('Insert > Table')
2.    Select the table.
3.    Create a new table from Selection,("Format  > Table > Create table from selection ' )
  
Actual results:
by keyboard operation, Uper case "r" needed, but the label shows a small case "r"

Expected results:

Additional info:
Comment 1 Matěj Cepl 2009-06-16 16:41:41 EDT
We filed this bug in the upstream database (https://bugzilla.mozilla.org/show_bug.cgi?id=498725) and believe that it is more appropriate to let it be resolved upstream.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

----------

For future reference: the golden rule of bug filing is "One bug per one issue". Actually, this latter turned to be one issue ("Alt+<letter> is not the same as <letter> in submenus"), but your original bug report wasn't.

Moreover, please do check for duplicates, issue 1 was a duplicate of two bugs at once (bug 472023 and bug 491103).

Note You need to log in before you can comment on or make changes to this bug.