Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 50610 - save changes does not work
save changes does not work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 12:05 EDT by Gene Czarcinski
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-01 16:47:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-08-01 12:05:34 EDT
Description of Problem:
Define a remote unix lpd printer.
After executing <File->Save Changes> look a /etc/printcap -- still the
same.

Only after exiting printconf-gui are the changes saved.

How Reproducible:


Steps to Reproduce:
1. Using printconf-gui, define a remote unix lpd printer
2. File->Save Changes
3. less /etc/printcap (no changes)
4. exit printconf-gui
5. less /etc/printcap (changes not in place)
5. printsomething using a2ps

Actual Results:
changes NOT saved

Expected Results:
changes saved

Additional Information:
Comment 1 Gene Czarcinski 2001-08-01 13:15:09 EDT
still does not work under printconf-0.3.6 from rawhide
Comment 2 Crutcher Dunnavant 2001-08-01 16:25:32 EDT
When you quit, do you get the "You have made changes" dialog?
What do you tell it?

Saving changes explicitly, through the menu, does not restart lpd.
Changes are only applied to the queue when lpd is restarted.
The old 'Apply' button did both, but it confused people. So now I just track
changes, and ask the user if they want to save. If they say yes, I save /and/
restart.

But the menu items only do what they say. So, if you saved, and then quit
without letting it 'save', then lpd was not restarted, and you did not get the
changes yet.
Comment 3 Glen Foster 2001-08-01 16:29:39 EDT
This defect is considered MUST-FIX for Fairfax
Comment 4 Gene Czarcinski 2001-08-01 16:47:52 EDT
After doing
save-changes I looked at /etc/printcap and it was not changed.  I was prepared
to manually do the restart but since printcap had not changed, this was not done.

My understanding is that save changes should update /etc/printcap but not
restart -- but it did not seem to do that.

If you do a restart without a save then it should restart with the old version
of printcap, etc.

Yes, exiting did save the changes and restarted lpd thereafter everything was OK.

The version in rawhide is much better than the on in beta3.
Comment 5 Crutcher Dunnavant 2001-08-01 16:58:47 EDT
I disagree. /etc/printcap needs to represent the current state of the server.
The changes are being saved through the alchemist, which one day will be a bit
more serious than just local changes.

Anyway, the thing in rawhide fixes many brown paper bag bugs.
Comment 6 Gene Czarcinski 2001-08-01 17:11:32 EDT
Right now, Save changes does not seem to do anything.

I did save-changes (no change to printcap) and then I did restart LPD and the
changes were saved before restarting.

Then I tried adding a new definition and just did restart (NO save-changes) ---
printcap was not changed.

While I can see that there is some logic to the way things are working, I
believe that it makes more sense (is more intuitive) for save changes to update
printcap.

Regardless, now that I understand what is happening, it is no big deal for me.
This only issue is how others (e.g., new users) will interpret things.

Perhaps this is an issue to be discussed on the testers-list for others to chime in.

Note You need to log in before you can comment on or make changes to this bug.