Bug 506124 - gcc-4.4.0-4.x86_64 missing dependency
gcc-4.4.0-4.x86_64 missing dependency
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
11
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 12:56 EDT by Tim Scofield
Modified: 2009-06-15 13:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 13:07:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Scofield 2009-06-15 12:56:25 EDT
Description of problem:
On Fedora release 11 (Leonidas) gcc-4.4.0-4.x86_64 owns /usr/lib/gcc/x86_64-redhat-linux/4.4.0/32/libgcc_s.so which is a link to a non existent /lib/libgcc_s.so.1 

There are several other broken links owned by gcc packages in this directory:
find . -type l | (while read FN ; do test -e "$FN" || ls -d "$FN"; rpm -qf "$FN"; done)
./libmudflap.a
gcc-4.4.0-4.x86_64
./libgomp.so
gcc-4.4.0-4.x86_64
./libstdc++.a
gcc-c++-4.4.0-4.x86_64
./libstdc++.so
gcc-c++-4.4.0-4.x86_64
gcc-4.4.0-4.x86_64
./libmudflapth.a
gcc-4.4.0-4.x86_64
./libgfortran.so
gcc-gfortran-4.4.0-4.x86_64
Note: libgcc_s.so is not listed here because I installed libgcc-4.4.0-4.i586


Version-Release number of selected component (if applicable):
4.4.0-4.x86_64

How reproducible:
Very

Steps to Reproduce:
1.Install gcc.x86_64
2.Look in /usr/lib/gcc/x86_64-redhat-linux/4.4.0/32 
3.Note the broken links
  
Actual results:
See list of broken links above

Expected results:
Either the 32 bit packages are available from some other package, or the gcc.x86_64 packages depend on and install the 32 bit libraries

Additional info:
Comment 1 Jakub Jelinek 2009-06-15 13:07:04 EDT
That's intentional.  We don't want to force both 64-bit and 32-bit devel environments onto everybody just because a single gcc can support both 64-bit and 32-bit compilation.
If you want to compile/link 32-bit stuff on x86-64, just make sure you install the relevant lib*.i586 packages.

Note You need to log in before you can comment on or make changes to this bug.