Bug 506163 - Deprecation message issued for udevinfo when plugging in a USB smart card
Deprecation message issued for udevinfo when plugging in a USB smart card
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openct (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 15:34 EDT by Bob Hill
Modified: 2009-11-10 02:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 02:49:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Hill 2009-06-15 15:34:03 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4

When plugging in an OMNIKEY USB smart card, the following message is issued:

"udevadm[4484]: the program '/bin/bash' called 'udevinfo', it should use 'udevadm info <options>', this will stop working in a future release"

Strongly suspect that this happens because  /lib/udev/openct_usb  is still using udevinfo, whereas maybe it ought really to be using udevadm nowadays.

The Fedora 11 system is fully up-to-date  (but without any rawhide), and contains openct package  openct-0.6.15-4.fc11.i586

Reproducible: Always

Steps to Reproduce:
1. Plug in a USB smart card in order to invoke openct code.
2. Deprecation message for udevinfo is issued.
3. USB smart card works fine, however.
Actual Results:  
Message issued:
"udevadm[4484]: the program '/bin/bash' called 'udevinfo', it should use 'udevadm info <options>', this will stop working in a future release"

USB smart card works fine, however.

Expected Results:  
Deprecation message for udevinfo should not be issued.
USB smart card software  (strongly suspect openct)  should use udevadm instead.

Here is the complete sequence of messages received when plugging in the USB:

Jun 15 20:52:49 fc11 kernel: usb 1-2: new full speed USB device using uhci_hcd and address 5
Jun 15 20:52:49 fc11 kernel: usb 1-2: New USB device found, idVendor=076b, idProduct=6622
Jun 15 20:52:49 fc11 kernel: usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jun 15 20:52:49 fc11 kernel: usb 1-2: Product: Smart Card Reader USB
Jun 15 20:52:49 fc11 kernel: usb 1-2: Manufacturer: OMNIKEY AG
Jun 15 20:52:49 fc11 kernel: usb 1-2: configuration #1 chosen from 1 choice
Jun 15 20:52:49 fc11 udevadm[4502]: the program '/bin/bash' called 'udevinfo', it should use 'udevadm info <options>', this will stop working in a future release
Jun 15 20:52:49 fc11 pcscd: hotplug_libhal.c:342:HPAddDevice() Adding USB device: usb_device_76b_6622_noserial_if0
Jun 15 20:52:50 fc11 pcscd: readerfactory.c:999:RFInitializeReader() Attempting startup of Generic CCID Reader 00 00 using /usr/lib/pcsc/drivers/openct-ifd.bundle/Contents/Linux/openct-ifd.so
Jun 15 20:52:50 fc11 pcscd: readerfactory.c:842:RFBindFunctions() Loading IFD Handler 2.0
Jun 15 20:52:50 fc11 pcscd: readerfactory.c:248:RFAddReader() Using the pcscd polling thread
Jun 15 20:52:50 fc11 pcscd: Card ATR: 3B FA 18 00 FF 81 31 FE 45 4A 43 4F 50 34 31 56 32 32 31 62
Comment 1 Tomas Mraz 2009-06-16 03:37:08 EDT
Fixed in rawhide openct-0.6.16-1.fc12.

Note You need to log in before you can comment on or make changes to this bug.