Bug 506197 - No Sound with SB Live!
No Sound with SB Live!
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 20:34 EDT by sangu
Modified: 2009-06-16 19:20 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.9.15-14.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-16 19:20:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2009-06-15 20:34:14 EDT
Description of problem:
$ pulseaudio -vvv
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
W: ratelimit.c: 27167 events suppressed
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: alsa-sink.c: Wakeup from ALSA!
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: protocol-native.c: Requesting rewind due to end of underrun.
D: protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
Soft CPU time limit exhausted, terminating.
E: cpulimit.c: Received request to terminate due to CPU overload.
I: main.c: Daemon shutdown initiated.
I: module.c: Unloading "module-device-restore" (index: #0).
I: module.c: Unloaded "module-device-restore" (index: #0).
I: module.c: Unloading "module-stream-restore" (index: #1).
I: module.c: Unloaded "module-stream-restore" (index: #1).
I: module.c: Unloading "module-card-restore" (index: #2).
I: module.c: Unloaded "module-card-restore" (index: #2).
I: module.c: Unloading "module-augment-properties" (index: #3).
I: module.c: Unloaded "module-augment-properties" (index: #3).
I: module.c: Unloading "module-alsa-card" (index: #4).
D: alsa-sink.c: hwbuf_unused=0
D: alsa-sink.c: setting avail_min=7232
D: module-suspend-on-idle.c: Sink alsa_output.pci_1102_2_sound_card_0 becomes idle.
D: alsa-sink.c: Requested to rewind 32768 bytes.
D: alsa-sink.c: Mhmm, actually there is nothing to rewind.
D: module-suspend-on-idle.c: Sink alsa_output.pci_1102_2_sound_card_0 becomes idle.
D: core.c: Hmm, no streams around, trying to vacuum.
I: sink-input.c: Freeing input 0 "audio stream"
D: core-subscribe.c: Dropped redundant event due to remove event.
D: alsa-sink.c: Thread shutting down
I: sink.c: Freeing sink 0 "alsa_output.pci_1102_2_sound_card_0"
I: source.c: Freeing source 0 "alsa_output.pci_1102_2_sound_card_0.monitor"
D: core-subscribe.c: Dropped redundant event due to change event.
D: alsa-source.c: Thread shutting down
I: source.c: Freeing source 1 "alsa_input.pci_1102_2_sound_card_0"
I: card.c: Freed 0 "alsa_card.pci_1102_2_sound_card_0"
I: module.c: Unloaded "module-alsa-card" (index: #4).
I: module.c: Unloading "module-alsa-card" (index: #5).
D: alsa-sink.c: Thread shutting down
I: sink.c: Freeing sink 1 "alsa_output.pci_10de_774_sound_card_0"
I: source.c: Freeing source 2 "alsa_output.pci_10de_774_sound_card_0.monitor"
D: alsa-source.c: Thread shutting down
I: source.c: Freeing source 3 "alsa_input.pci_10de_774_sound_card_0"
I: card.c: Freed 1 "alsa_card.pci_10de_774_sound_card_0"
I: module.c: Unloaded "module-alsa-card" (index: #5).
I: module.c: Unloading "module-hal-detect" (index: #6).
I: module.c: Unloaded "module-hal-detect" (index: #6).
I: module.c: Unloading "module-bluetooth-discover" (index: #7).
I: module.c: Unloaded "module-bluetooth-discover" (index: #7).
I: module.c: Unloading "module-esound-protocol-unix" (index: #8).
I: module.c: Unloaded "module-esound-protocol-unix" (index: #8).
I: module.c: Unloading "module-native-protocol-unix" (index: #9).
I: client.c: Freed 1 "MPlayer"
I: module.c: Unloaded "module-native-protocol-unix" (index: #9).
I: module.c: Unloading "module-gconf" (index: #10).
I: module.c: Unloaded "module-gconf" (index: #10).
I: module.c: Unloading "module-default-device-restore" (index: #11).
I: module.c: Unloaded "module-default-device-restore" (index: #11).
I: module.c: Unloading "module-rescue-streams" (index: #12).
I: module.c: Unloaded "module-rescue-streams" (index: #12).
I: module.c: Unloading "module-always-sink" (index: #13).
I: module.c: Unloaded "module-always-sink" (index: #13).
I: module.c: Unloading "module-suspend-on-idle" (index: #14).
I: module.c: Unloaded "module-suspend-on-idle" (index: #14).
I: module.c: Unloading "module-console-kit" (index: #15).
D: module-console-kit.c: Removing session /org/freedesktop/ConsoleKit/Session2
I: client.c: Freed 0 "ConsoleKit Session /org/freedesktop/ConsoleKit/Session2"
I: module.c: Unloaded "module-console-kit" (index: #15).
I: module.c: Unloading "module-position-event-sounds" (index: #16).
I: module.c: Unloaded "module-position-event-sounds" (index: #16).
I: module.c: Unloading "module-cork-music-on-phone" (index: #17).
I: module.c: Unloaded "module-cork-music-on-phone" (index: #17).
I: main.c: Daemon terminated.

$dmesg 
[...]
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x200c, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x200c, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x200c, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x200c, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x200c, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2006, buffer size = 0x2000, period size = 0x2000
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x200c, buffer size = 0x2000, period size = 0x2000
__ratelimit: 21 callbacks suppressed
ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000

Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-11.fc11.

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Internal audio (HDA-Intel) is OK!

$ cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe020000 irq 20
 1 [Live           ]: EMU10K1 - SB Live! Platinum [CT4760P]
                      SB Live! Platinum [CT4760P] (rev.7, serial:0x80401102) at 0xec00, irq 18
Comment 1 sangu 2009-06-16 19:20:38 EDT
Fixed in pulseaudio-0.9.15-14.fc11.x86_64.

Note You need to log in before you can comment on or make changes to this bug.