Bug 506257 - Job with multiple files get removed when printer is disable/enabled
Job with multiple files get removed when printer is disable/enabled
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cups (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tim Waugh
BaseOS QE
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 08:43 EDT by Olivier Fourdan
Modified: 2013-03-03 21:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-30 04:14:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (488 bytes, patch)
2009-06-16 08:43 EDT, Olivier Fourdan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 3226 None None None Never

  None (edit)
Description Olivier Fourdan 2009-06-16 08:43:04 EDT
Created attachment 348100 [details]
Proposed patch

Description of problem:

This is the same as bug #432001 for enable/disable printer.

When a job with multiple files is in the queue when the printer is disabled, the job gets deleted when the printer is enabled again and the job is not printed.

Version-Release number of selected component (if applicable):

cups-1.3.7-8.el5_3.6

How reproducible:

100% reproducible

Steps to Reproduce:
1) Setup a printer:

  # /usr/sbin/lpadmin -p testprinter -E -v socket://127.0.0.1:9100 -m textonly.ppd

2) Create a few files to print:

  # echo "test print 1" > print1.txt
  # echo "test print 2" > print2.txt

3) Print two or more files by using the lp command:

  # lp -d testprinter print1.txt print2.txt
request id is testprinter-1 (2 file(s))

4) Make sure the jobs are still listed 

  # lpstat -o

  testprinter-483         ofourdan          2048   Tue 16 Jun 2009 01:38:36 PM BST

5) Disable the printer

  # cupsdisable testprinter

6) Make sure the jobs are still listed 

  # lpstat testprinter
  testprinter-483         ofourdan          2048   Tue 16 Jun 2009 01:38:36 PM BST
 
7) Re-enable the printer

  # cupsenable testprinter

8) Check for the job

  # lpstat testprinter
 
Actual results:

  Jobs has been de-queued, lpstat returns nothing

Expected results:

  # lpstat testprinter
  testprinter-483         ofourdan          2048   Tue 16 Jun 2009 01:38:36 PM BST

Additional info:

This is the same as bug #432001, the fix is very similar. Proposed patch attached.

PS: the bug seems to be present upstream too (at least in cups-1.3.10)
Comment 1 Tim Waugh 2009-06-16 10:41:45 EDT
Thanks.  Reported upstream.
Comment 2 Tim Waugh 2009-06-18 17:32:49 EDT
Accepted upstream.
Comment 9 errata-xmlrpc 2010-03-30 04:14:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0210.html

Note You need to log in before you can comment on or make changes to this bug.