Bug 506297 - Document kdump directives
Document kdump directives
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Realtime_Tuning_Guide (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Lana Brindley
David Sommerseth
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 12:14 EDT by Jon Thomas
Modified: 2016-05-22 19:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 01:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Thomas 2009-06-16 12:14:01 EDT
Description of problem:


MRG documentation doesn't match kdump documentation for setting up kdump.conf.

It looks like the following should be changed in

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_MRG/1.0/html/Realtime_Tuning_Guide/sect-Realtime_Tuning_Guide-Realtime_Specific_Tuning-Using_kdump_and_kexec_with_the_RT_kernel.html

from-->

2. By default, the crash dump is saved in the /var/crash file. If you wish to change this, simply uncomment and adjust the path value in the /etc/kdump.conf file. This can be a local file, or on another server.

...[output truncated]...
#raw /dev/sda5
#ext3 /dev/sda3
#ext3 LABEL=/boot
#ext3 UUID=03138356-5e61-4ab3-b58e-27507ac41937
#net my.server.com:/export/tmp
#net user@my.server.com

path /path/to/file

...

to --->

2. Kdump can be configured to mount a partition and dump to a file on disk. This is done by specifying the filesystem type, followed by the partition in kdump.conf. The partition may be specified as a device name, a filesystem label, or UUID in the same manner as /etc/fstab. See example below. The default directory in which the core will be dumped is /var/crash/%DATE/ where %DATE is the current date at the time of the cash dump. If you wish to change this, simply uncomment and adjust the path value in the /etc/kdump.conf file. This can be a local file, or on another server. Additional information is provided by the kexec-tools package and is installed at /usr/share/doc/kexec-tools-2.0.0/kexec-kdump-howto.txt.

...[output truncated]...
#raw /dev/sda5
#ext3 /dev/sda3
#ext3 LABEL=/boot
ext3 UUID=03138356-5e61-4ab3-b58e-27507ac41937
#net my.server.com:/export/tmp
#net user@my.server.com

path /path/to/file

Note You need to log in before you can comment on or make changes to this bug.