Bug 50630 - ks + network --bootproto static
ks + network --bootproto static
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 15:03 EDT by Gerald Teschl
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-08-01 15:03:45 EDT
For various reasons I cannot use dhcp for my ks installation. Morover,
since I want to use the same boot floppy for different machines I do not
know the ip address when creating the ks floppy. Hence I put

network --bootproto static

into the ks.cfg file and expected anaconda to prompt me for the
tcp/ip configuration. However, anacondo tries to use dhcp and then,
after dhcp timed out, asks me for keybord, lang, tcp/ip, nfsserver
even tough keyboard, lang, nfsserver is present in the ks.cfg!?

Could you please fix this and, even better, it would be nice if it were
possibel to just specify some part of the tcp/ip config
(netmask,gw,nameserver) and anaconda would use these as default vaues.
I think this would be a very valuable feature for many users.
Comment 1 Brent Fox 2001-08-03 15:06:19 EDT
What if you just left the network section out altogether?  Does the installer
prompt you for the network information?  The reason the installer is prompting
you for all the information is that you haven't given enough data on the network
line.  You can't just say 'network --bootproto static'.  Therefore, the
installer determines that the format of the kickstart file is wrong, so it
throws out the kickstart file and starts a normal install.
Comment 2 Gerald Teschl 2001-08-06 15:48:53 EDT
I just tired to let the network part out but it makes no difference.
Comment 3 Brent Fox 2001-08-10 17:43:36 EDT
There's currently no way to do this with kickstart.  We can't add this feature
now...deferring to a future release.
Comment 4 Brent Fox 2002-01-22 01:06:23 EST
katzj, do you want to add this to kickstart?
Comment 5 Jeremy Katz 2002-01-22 01:12:16 EST
It's a dupe of a few others assigned to me at the moment... unsure if it will be
gotten to for this release or not, though.
Comment 6 Gerald Teschl 2002-01-22 11:37:12 EST
At least it should only ask for network numbers (and not ask for
keyboard,nfsserver, etc.) if the network section is left out. Thanks
for looking into this.
Comment 7 Michael Fulbright 2002-03-26 12:44:09 EST
Deferring to future release.
Comment 8 Gerald Teschl 2002-05-08 14:54:25 EDT
Please consider this for the next release. Thanks.
Comment 9 Red Hat Bugzilla 2006-02-21 13:48:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.