Bug 506333 - Badness in udp_poll from local_bh_enable
Badness in udp_poll from local_bh_enable
Status: CLOSED DUPLICATE of bug 459185
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.7
All Linux
low Severity medium
: rc
: ---
Assigned To: Danny Feng
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 14:09 EDT by Craig Magina
Modified: 2010-12-10 15:54 EST (History)
0 users

See Also:
Fixed In Version: 78.23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-10 15:54:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Craig Magina 2009-06-16 14:09:04 EDT
Description of problem:
Get a badness dump stack from local_bh_enable.

Version-Release number of selected component (if applicable):


How reproducible:
Just running a 4.7 RHEL system as a Xen guest, although this would be reproducible on baremetal as well.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
This is fixed upstream by commit 208d89843b7b03978d8e748b8b991c1be81c4f43 to Linus's tree.

[IPV4]: Fix BUG() in 2.6.x, udp_poll(), fragments + CONFIG_HIGHMEM

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blobdiff;f=net/ipv4/udp.c;h=7c24e64b443f80eae0c5a3663caff46f37011f69;hp=4a6952e3fee95d35d6477c82aff274b3b2bdf4da;hb=208d89843b7b03978d8e748b8b991c1be81c4f43;hpb=9bb7bc942d3da606f184ac6a4dfc7e4d470c831b
Comment 2 Linda Wang 2010-12-10 15:54:08 EST

*** This bug has been marked as a duplicate of bug 459185 ***

Note You need to log in before you can comment on or make changes to this bug.