Bug 506386 - Internal GStreamer error when launching totem. [NEEDINFO]
Internal GStreamer error when launching totem.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: liboil (Show other bugs)
5.3
ia64 Linux
low Severity medium
: rc
: ---
Assigned To: Wim Taymans
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-16 23:36 EDT by XinSun
Modified: 2014-06-02 09:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:07:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (xinsun)


Attachments (Terms of Use)
GStreamer-error.png (76.42 KB, image/png)
2009-06-16 23:36 EDT, XinSun
no flags Details

  None (edit)
Description XinSun 2009-06-16 23:36:58 EDT
Created attachment 348204 [details]
GStreamer-error.png

Description of problem:
When launching totem, an error message pops up said:Internal GStreamer error.But after close this error message, totem can still work.

Version-Release number of selected component (if applicable):
totem-2.16.7-6.el5 

How reproducible:
Always

Steps to Reproduce:
1.Click "Applications" menu,choose "Sound & Video" -> "Movie Player". 
or you can run command "totem" in terminal.
  
Actual results:
An error message pops up said " Internal GStreamer error:state changed failed."

Expected results:
Totem can launch successfully without any error message.

Additional info:
Please see the attachment "GStream-error.png"
Comment 1 Bastien Nocera 2009-06-17 04:50:03 EDT
That report is useless to me. Check on the command-line whether any more error reporting is done, failing that, launch totem with "GST_DEBUG=*:3" to get some debug out of it.
Comment 2 XinSun 2009-06-17 06:01:49 EDT
After run "totem" in command-line, the error message reporting is:

.qa.[root@ia64-5s-m2 ~]# totem
OIL: ERROR liboiltest.c 403: oil_test_check_impl(): function conv_u16_f32_lrintf in class conv_u16_f32 failed check (1.24513e+06 > 0.1) || (outside=0)
OIL: ERROR liboiltest.c 403: oil_test_check_impl(): function conv_u16_f32_lrint in class conv_u16_f32 failed check (1.24513e+06 > 0.1) || (outside=0)
OIL: ERROR liboiltest.c 403: oil_test_check_impl(): function conv_u8_f32_lrintf in class conv_u8_f32 failed check (6843 > 0.1) || (outside=0)
OIL: ERROR liboiltest.c 403: oil_test_check_impl(): function conv_u8_f32_lrint in class conv_u8_f32 failed check (6843 > 0.1) || (outside=0)
totem(6728): unaligned access to 0x60000000006f1694, ip=0x200000000b95d960
totem(6728): unaligned access to 0x60000000006f1424, ip=0x200000000b95d970
totem(6728): unaligned access to 0x60000000006f169c, ip=0x200000000b95d980
totem(6728): unaligned access to 0x60000000006f142c, ip=0x200000000b95d990
totem(6728): unaligned access to 0x60000000006f16a4, ip=0x200000000b95d9a0
Comment 3 Bastien Nocera 2009-06-17 06:49:25 EDT
liboil failures.
Comment 5 RHEL Product and Program Management 2014-03-07 08:38:54 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 6 RHEL Product and Program Management 2014-06-02 09:07:14 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.