Bug 506445 - cups returns document format error with Samsung ML-1640 laser printer
cups returns document format error with Samsung ML-1640 laser printer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 07:34 EDT by Colin Brace
Modified: 2009-07-11 08:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 13:56:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups error_log (3.49 MB, text/plain)
2009-06-18 04:57 EDT, Colin Brace
no flags Details

  None (edit)
Description Colin Brace 2009-06-17 07:34:58 EDT
cups version: cups-1.4-0.b2.18.fc11.i586 

After upgrading my desktop system from Fedora 10 to 11 several days ago using yum, my Samsung ML-1640 laser printer no longer works. 

Here is a relevant snippet from /var/log/cups/error_log:

[...]
I [17/Jun/2009:12:31:14 +0200] [Job 289] Queued on "ML-1640-Series" by "colin".
D [17/Jun/2009:12:31:14 +0200] Returning IPP successful-ok for Create-Job (ipp://localhost:631/printers/ML-1640-Series) from localhost
D [17/Jun/2009:12:31:14 +0200] cupsdReadClient: 20 POST /printers/ML-1640-Series HTTP/1.1
D [17/Jun/2009:12:31:14 +0200] cupsdAuthorize: No authentication data provided.
D [17/Jun/2009:12:31:14 +0200] Send-Document ipp://localhost:631/printers/ML-1640-Series
D [17/Jun/2009:12:31:14 +0200] cupsdIsAuthorized: requesting-user-name="colin"
D [17/Jun/2009:12:31:14 +0200] [Job 289] Auto-typing file...
D [17/Jun/2009:12:31:14 +0200] [Job 289] Request file type is application/postscript.
D [17/Jun/2009:12:31:14 +0200] Send-Document client-error-document-format-not-supported: Unsupported format 'application/postscript'!
E [17/Jun/2009:12:31:14 +0200] Returning IPP client-error-document-format-not-supported for Send-Document (ipp://localhost:631/printers/ML-1640-Series) from localhost
D [17/Jun/2009:12:31:14 +0200] cupsdReadClient: 20 POST /jobs/ HTTP/1.1
D [17/Jun/2009:12:31:14 +0200] cupsdAuthorize: No authentication data provided.
D [17/Jun/2009:12:31:14 +0200] Cancel-Job ipp://localhost:631/printers/ML-1640-Series
I [17/Jun/2009:12:31:14 +0200] [Job 289] Job canceled by "colin"
I [17/Jun/2009:12:31:14 +0200] [Job 289] Canceled by "colin".
D [17/Jun/2009:12:31:14 +0200] Returning IPP successful-ok for Cancel-Job (ipp://localhost:631/printers/ML-1640-Series) from localhost
[...]

To be explicit: this printer worked fine under F10.
Comment 1 Tim Waugh 2009-06-17 10:09:38 EDT
Please attach the entire error_log file.  Thanks.
Comment 2 Martí­n Marqués 2009-06-17 22:37:51 EDT
I have similar problems with a Lexmark E120. Looks like USB problems.
Comment 3 Andre Robatino 2009-06-18 01:13:36 EDT
I have a Samsung ML-1740 which I believe uses the same driver as the ML-1640, and after a clean install of F11 it appears to work fine.
Comment 4 Tim Waugh 2009-06-18 04:38:45 EDT
(In reply to comment #2)
> Looks like USB problems.  

That's definitely not it.  It doesn't get as far as that.  The print job is not yet created, and for some reason CUPS won't accept the job.

I really need the full /var/log/cups/error_log file from someone who sees this problem.
Comment 5 Andre Robatino 2009-06-18 04:44:26 EDT
Forgot to mention that my working printer is connected via USB.
Comment 6 Colin Brace 2009-06-18 04:57:54 EDT
Created attachment 348397 [details]
cups error_log
Comment 7 Tim Waugh 2009-06-18 05:11:19 EDT
Thanks!  Now please show me the output of this command:

stat /usr/lib/cups/filter/rastertosamsungspl

Thanks.
Comment 8 Colin Brace 2009-06-18 05:43:27 EDT
$ stat /usr/lib/cups/filter/rastertosamsungspl
  File: `/usr/lib/cups/filter/rastertosamsungspl'
  Size: 61520     	Blocks: 136        IO Block: 4096   regular file
Device: 803h/2051d	Inode: 97426       Links: 1
Access: (0555/-r-xr-xr-x)  Uid: (  500/   colin)   Gid: (  500/   colin)
Access: 2009-06-17 03:55:50.000000000 +0200
Modify: 2007-12-07 07:15:11.000000000 +0100
Change: 2009-05-14 05:07:06.000000000 +0200
Comment 9 Tim Waugh 2009-06-18 05:53:09 EDT
How did you install that file?  Was it from an RPM?
Comment 10 Colin Brace 2009-06-18 06:48:01 EDT
No, I copied it manually from the Samsung CD that came with the printer. For the sake of completeness, I will mention that I installed these four files by hand:

$ sudo cp -vp pscms rastertosamsung* /usr/lib/cups/filter/

`pscms' -> `/usr/lib/cups/filter/pscms'
`rastertosamsungpcl' -> `/usr/lib/cups/filter/rastertosamsungpcl'
`rastertosamsungspl' -> `/usr/lib/cups/filter/rastertosamsungspl'
`rastertosamsungsplc' -> `/usr/lib/cups/filter/rastertosamsungsplc'
Comment 11 Andre Robatino 2009-06-18 06:59:12 EDT
That's probably your mistake.  Your printer should work fine using Fedora's built-in drivers, with the possible exception of a few esoteric features that almost nobody uses.  In addition, you get automatic updates.  The stuff on Samsung's CD could be years old.

http://openprinting.org/show_printer.cgi?recnum=Samsung-ML-1640
Comment 12 Andre Robatino 2009-06-18 07:02:49 EDT
Actually, the driver Fedora uses is probably foomatic/gdi (that's the one mine uses, and I'm pretty sure it's the same for yours).
Comment 13 Andre Robatino 2009-06-18 07:07:04 EDT
Sorry, I checked the openprinting.org database and while the gdi driver covers many earlier Samsung printers, the ML-1640 isn't one of them.  Nevertheless, you should try the built-in driver before installing Samsung's proprietary stuff.
Comment 14 Tim Waugh 2009-06-18 13:56:54 EDT
(In reply to comment #10)
> No, I copied it manually from the Samsung CD that came with the printer.

OK.  The problem is that it needs to be owned by root, and isn't.
Comment 15 Colin Brace 2009-06-18 14:36:18 EDT
Thanks Tim, that fixed it.
Comment 16 Michael Schwendt 2009-07-11 08:33:00 EDT
For the Samsung ML-1640 one doesn't strictly need Samsung's UPD. One can point Cups at the ML-1610 driver, and that one works, at least for the test page.

Note You need to log in before you can comment on or make changes to this bug.