Bug 506487 - Dies shortly after starting
Dies shortly after starting
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 10:08 EDT by Bastien Nocera
Modified: 2009-10-26 10:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 10:36:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pa.log.bz2 (13.48 KB, application/octet-stream)
2009-06-19 11:58 EDT, Bastien Nocera
no flags Details
Pulseaudio log (34.30 KB, application/octet-stream)
2009-10-26 10:30 EDT, Adam Huffman
no flags Details

  None (edit)
Description Bastien Nocera 2009-06-17 10:08:47 EDT
kernel-2.6.29.4-167.fc11.x86_64
pulseaudio-0.9.15-14.fc11.x86_64
gstreamer-plugins-good-0.10.15-1.fc11.x86_64

Bus 001 Device 005: ID 0ccd:0028 TerraTec Electronic GmbH Aureon 5.1 MkII

PA dies after less than 2 minutes of playback through rhythmbox:
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: ratelimit.c: 360 events suppressed
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: ratelimit.c: 512 events suppressed
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
W: asyncq.c: q overrun, queuing locally
Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.
Aborted
Comment 1 Lennart Poettering 2009-06-19 11:53:34 EDT
Hmpf. Culd you get me the full debug output of such a run? i.e. in a terminal "pulseaudio -vvvvv" and then paste that? Please don't truncate the output.
Comment 2 Lennart Poettering 2009-06-19 11:54:40 EDT
the "q overrun, queuing locally" stuff is usally because of a misbehaving client which doesn't process its messages quickly enough.
Comment 3 Bastien Nocera 2009-06-19 11:58:33 EDT
Created attachment 348680 [details]
pa.log.bz2

Compressed output of pulseaudio.
Comment 4 Bastien Nocera 2009-06-22 05:32:16 EDT
Passing --no-cpu-limit avoids the assertion, and works well. How can I monitor CPU usage over time?
Comment 5 Lennart Poettering 2009-06-29 08:53:07 EDT
(In reply to comment #4)
> Passing --no-cpu-limit avoids the assertion, and works well. How can I monitor
> CPU usage over time?  

Hmm, that GNOME system monitor applet? That monitors overall CPU load, but that should be good enough, shouldn't it?
Comment 6 Bastien Nocera 2009-07-22 00:03:43 EDT
Seems to work fine now...
Comment 7 Adam Huffman 2009-10-26 10:24:23 EDT
Just encountered this for the first time on an F11 system.  Have been trying to play a video file using both Totem and VLC.  In each case, the playback freezes after approximately 2-3 minutes.  Only then did I notice the multiple:

pulseaudio[2871]: asyncq.c: q overrun, queuing locally

errors in /var/log/messages.  I will post the output of pulseaudio -vvvv separately.
Comment 8 Adam Huffman 2009-10-26 10:30:06 EDT
Created attachment 366107 [details]
Pulseaudio log

Output of 'pulseaudio -vvvvv'
Comment 9 Adam Huffman 2009-10-26 10:31:08 EDT
There are also a couple of these in /var/log/messages:

Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c: snd_pcm_avail() returned a value that is exceptionally large: 6377097072356602472 bytes (326791809583 ms).
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c: snd_pcm_dump():
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c: Hooks PCM
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c: Its setup is:
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   stream       : PLAYBACK
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   access       : MMAP_INTERLEAVED
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   format       : S16_LE
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   subformat    : STD
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   channels     : 2
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   rate         : 44100
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   exact rate   : 44100 (44100/1)
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   msbits       : 16
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   buffer_size  : 88192
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   period_size  : 44096
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   period_time  : 999909
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   tstamp_mode  : ENABLE
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   period_step  : 1
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   avail_min    : 87311
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   period_event : 0
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   start_threshold  : -1
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   stop_threshold   : 6205960286516543488
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   silence_threshold: 0
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   silence_size : 0
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   boundary     : 6205960286516543488
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c: Slave: Hardware PCM card 2 'HDA ATI HDMI' device 3 subdevice 0
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c: Its setup is:
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   stream       : PLAYBACK
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   access       : MMAP_INTERLEAVED
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   format       : S16_LE
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   subformat    : STD
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   channels     : 2
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   rate         : 44100
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   exact rate   : 44100 (44100/1)
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   msbits       : 16
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   buffer_size  : 88192
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   period_size  : 44096
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   period_time  : 999909
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   tstamp_mode  : ENABLE
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   period_step  : 1
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   avail_min    : 87311
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   period_event : 0
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   start_threshold  : -1
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   stop_threshold   : 6205960286516543488
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   silence_threshold: 0
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   silence_size : 0
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   boundary     : 6205960286516543488
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   appl_ptr     : 181354
Oct 26 14:18:16 marcel pulseaudio[6686]: alsa-util.c:   hw_ptr       : 88196
Comment 10 Bastien Nocera 2009-10-26 10:36:00 EDT
(In reply to comment #7)
> Just encountered this for the first time on an F11 system.

Open your own bug...

Note You need to log in before you can comment on or make changes to this bug.