Bug 506512 - broken layout on partitioning screen
broken layout on partitioning screen
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 11:24 EDT by Matthias Clasen
Modified: 2009-07-23 15:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-23 15:00:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (78.94 KB, image/png)
2009-06-17 11:24 EDT, Matthias Clasen
no flags Details

  None (edit)
Description Matthias Clasen 2009-06-17 11:24:47 EDT
Created attachment 348274 [details]
screenshot

Notice the lack of space between the action area and the content.

I also think the checkbox would be better off as part of the content, instead of sitting next to the buttons.
Comment 1 Jeremy Katz 2009-06-17 11:29:44 EDT
The checkbox is part of the content, something is going wrong with the packing.

What resolution are you running at there?  Also, it looks like something weird is going on with font dpi (which then impacts the flow/packing)

We continue to have ongoing problems here from release to release even when we've changed nothing :/
Comment 2 Matthias Clasen 2009-06-24 11:51:02 EDT
This was a live cd install running on my old Dell, so probably 1920x1200.
The anaconda window was a small window in the middle of the screen...

> Also, it looks like something weird
> is going on with font dpi (which then impacts the flow/packing)

A fixed-size window is never going to work, regardless of dpi changes. But I don't think you are forcing the window size, or are you ?
Comment 3 Jeremy Katz 2009-06-24 13:42:04 EDT
(In reply to comment #2)
> This was a live cd install running on my old Dell, so probably 1920x1200.
> The anaconda window was a small window in the middle of the screen...

Which also probably means the xrandr call failed.
 
> > Also, it looks like something weird
> > is going on with font dpi (which then impacts the flow/packing)
> 
> A fixed-size window is never going to work, regardless of dpi changes. But I
> don't think you are forcing the window size, or are you ?  

No, we do force the window size.
Comment 4 Jeremy Katz 2009-07-23 15:00:06 EDT
Fix sent to anaconda-devel-list for review and will then be pushed for rawhide.  It's a little kludgey and a bit of a big hammer, but it'll solve the problem in the short term until we can do the bigger set of changes

Note You need to log in before you can comment on or make changes to this bug.