Bug 506560 - cronie no longer running @reboot jobs
cronie no longer running @reboot jobs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 14:29 EDT by Mace Moneta
Modified: 2009-06-30 03:17 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.3-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 11:06:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2009-06-17 14:29:26 EDT
Description of problem:

On the 16th, I updated to cronie-1.3-1.fc11.x86_64.  Today I rebooted.  The @reboot jobs did not start.  The cron log says:

Jun 17 14:17:00 slayer crond[2143]: (CRON) INFO (@reboot jobs will be run at computer's startup.)

Since the computer just started, cronie does not appear to be determining "computer startup" properly.  

Version-Release number of selected component (if applicable):

cronie-1.3-1.fc11.x86_64

How reproducible:

Always

Steps to Reproduce:
1.update to cronie-1.3-1.fc11.x86_64
2.Have @reboot jobs in your crontabs
3.reboot
  
Actual results:

@reboot jobs don't run

Expected results:

@reboot jobs run

Additional info: Verified the SELINUX in permissive doesn't change anything.
Comment 1 Mace Moneta 2009-06-17 14:55:35 EDT
The change appears to have been brought about by this commit:

https://fedorahosted.org/cronie/changeset/2abb46f60f496e2725333a86ade0f3913981761d
Comment 2 Marcela Mašláňová 2009-06-18 07:55:56 EDT
And it was fixed in git by 
https://fedorahosted.org/cronie/changeset/8d6855a32762dab036a28364a6e714b47c6f06c0

I'll add it into updates. Thank you for report.
Comment 3 Fedora Update System 2009-06-18 07:58:59 EDT
cronie-1.3-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/cronie-1.3-2.fc11
Comment 4 Mace Moneta 2009-06-18 11:06:34 EDT
Confirmed that cronie-1.3-2.fc11 corrects the problem.  Closing.
Comment 5 Fedora Update System 2009-06-26 23:00:01 EDT
cronie-1.3-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Nerijus Baliūnas 2009-06-29 21:56:23 EDT
Why this update started to require anacron?
Comment 7 Tomas Mraz 2009-06-30 02:50:32 EDT
*** Bug 508432 has been marked as a duplicate of this bug. ***
Comment 8 Tomas Mraz 2009-06-30 02:51:29 EDT
Because it needs it to run cron.daily, cron.weekly, and cron.monthly jobs.
Comment 9 Adrian Reber 2009-06-30 03:02:30 EDT
Sorry, but I don't get it. Where is the connection between cron.daily, cron.weekly, and cron.monthly and @reboot jobs? I would really prefer if there was no dependency on anacron. I really do not want cron jobs to start at a random time after I power my system on. Up until now it was a simple "rpm -e anacron" and everything was perfect.
Comment 10 Tomas Mraz 2009-06-30 03:17:17 EDT
But it was not at all perfect for the default use-case.

@reboot is not related to the weekly, etc. jobs I just answered the comment 6.

The duplicate notation in comment 7 is wrong though I've mistaked the bug number with another bug.

Note You need to log in before you can comment on or make changes to this bug.