Bug 506604 - rlwrap crashes when wrapped tool prevents character echo
rlwrap crashes when wrapped tool prevents character echo
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: rlwrap (Show other bugs)
el5
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 18:03 EDT by Lans Carstensen
Modified: 2010-10-11 13:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-11 13:42:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lans Carstensen 2009-06-17 18:03:59 EDT
Description of problem:

Type "rlwrap passwd" and press any key:

Changing password for user xxx.
Enter login(LDAP) password:
rlwrap: Oops, segfault -  this should not have happened!
If you need a core dump, re-configure with --enable-debug and rebuild
Resetting terminal and cleaning up...

This occurs for any program preventing character echo for password entry (e.g. tools that could really use readline like sqlplus).

Version-Release number of selected component (if applicable):

rlwrap-0.30-1.el5

How reproducible:

100%

Steps to Reproduce:

See above.

Actual results:

rlwrap SEGV's

Expected results:

No SEGV
Comment 1 Lans Carstensen 2009-06-17 18:18:33 EDT
Simply rebuilding from the EPEL source RPM addresses the SEGV on my RHEL 5.3 systems.  There is no newer "testing" version.  Can we get this EPEL rpm rebuilt?
Comment 2 Mark Chappell 2010-09-24 11:58:17 EDT
Looks like rlwrap was updated and rebuilt.

rlwrap.x86_64        0.37-1.el5      epel

Lans are you able to confirm that this bug has been fixed?
Comment 3 Lans Carstensen 2010-10-11 13:42:33 EDT
Yes, I can confirm that this is fixed.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.