Bug 506608 - Uploaded Source rpms not visible to the naked eye in satellite webui
Uploaded Source rpms not visible to the naked eye in satellite webui
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
520
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
: Regression
Depends On:
Blocks: 456985 499334
  Show dependency treegraph
 
Reported: 2009-06-17 18:23 EDT by Pradeep Kilambi
Modified: 2009-09-10 16:14 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:14:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2009-06-17 18:23:01 EDT
Description of problem:

Uploaded src rpms to satellite-5.3 dont show up in the webui. Apparently looks like we rewrote this page from perl to java and this is a regressions due to the conversion. The source rpm path if queried from Packages.java as getSourcePath method, but this call will never return a value as the filed is not queried top being with.

Spoke to jsherril and he confirmed the this was a regression due to the java port in 530.

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090612.0-x86_64


How reproducible:
always

Steps to Reproduce:
1. Push a source rpm
2. Push its equivalent binary
3. go to rhn/software/packages/Details.do?pid= page and only binary rpm shows up and src rpm is shows as missing.
  
Actual results:
no src rpm visible to the naked eye in satellite webui

Expected results:
uploaded source rpms should show up in the UI package details page

Additional info:
Comment 1 Justin Sherrill 2009-06-18 10:37:10 EDT
fixed 
e4ba5f3
Comment 2 wes hayutin 2009-06-23 13:32:48 EDT
verified
Comment 3 Michael Mráka 2009-08-04 04:34:49 EDT
Verified in stage -> RELEASE_PENDING.
Comment 4 Brandon Perkins 2009-09-10 16:14:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.