Bug 506614 - Fatal error loading floppy module
Fatal error loading floppy module
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 513462
  Show dependency treegraph
 
Reported: 2009-06-17 19:16 EDT by Ryan Fonnesbeck
Modified: 2009-11-04 18:36 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-04 18:36:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Fonnesbeck 2009-06-17 19:16:26 EDT
Description of problem:
Trying to install Fedora 11 on IBM HS21 BladeServer.  DVD, NFS, and NFS+Kickstart installations all exhibit same behaviour where anaconda does not seem to proceed to stage2.  After initial kernel messages, the screen goes black.

There is a fatal error message on vt/3 when the floppy kernel module tries to load.  (There is no floppy device on this system.)


How reproducible:
Always

Steps to Reproduce:
1.  Boot from installation DVD or initiate NFS installation
  
Actual results:
Anaconda does not seem to proceed to stage2.

Expected results:
Anaconda installation process should continue normally.

Additional info:

Initial kernel boot messaging displays normally.  After screen goes black, virtual terminals are no longer available.

Final messages before fading to black:

----- vt/1 ------
Greetings.
anaconda installer init version 11.5.0.59 starting
mounting /proc filesystem... done
creating /dev filesystem... done
starting udev...done
mounting /dev/pts (unix98 pty) filesystem... done
mounting /sys filesystem... done
trying to remount root filesystem read write... done
mounting /tmp as tmpfs... done
running install...
running /sbin/loader
detecting hardware...
waiting for hardware to initialize...

----- vt/2 ------
(Nothing -- no virtual terminal)

----- vt/3 ------
20:55:13 INFO    : kernel command line: nfsdir=xxx.xxx.xxx.xxx:/xxx/xxx initrd=fedora-11-x86-64/initrd.img text headless serial BOOT_IMAGE=fedora-11-x86_64/vmlinuz

20:55:13 INFO    : text mode forced from cmdline
20:55:13 INFO    : early networking required fro syslog
20:55:13 INFO    : anaconda version 11.5.0.59 on x86_64 starting
20:55:13 INFO    : text mode forced due to serial/virtpconsole
20:55:13 INFO    : 32692644 kB are available
FATAL: Error inserting floppy (/lib/modules/2.6.29.4-167.fc11.x86_64/kernel/drivers/block/floppy.ko.gz): No such device


Anaconda will proceed to stage 2 if the "noprobe" option is passed, but bug #499425 prevents NFS installation from proceeding.
Comment 1 Chris Lumens 2009-07-06 11:05:37 EDT
floppy.ko is one of the modules we unconditionally load, as it may be needed for a variety of update possibilities.
Comment 2 Peter McNabb 2009-07-28 13:51:43 EDT
It looks like the HS21 BladeServers require a "nomodeset" option to the kernel (for installation and afterwards). I was seeing similar behavior and after trial and error found that option to work.

The floppy error was a red herring.
Comment 3 Ryan Fonnesbeck 2009-07-28 17:36:49 EDT
I can confirm that this was, in fact, a display issue; and not an issue with the floppy module.  Passing the "nomodeset" option remedies the problem.

(Though I still think that reporting "FATAL" errors for non-fatal events warrants a bug report.)

Note You need to log in before you can comment on or make changes to this bug.