Bug 506615 - dependency problem with rhino 1.7 0.6.r2.fc11
dependency problem with rhino 1.7 0.6.r2.fc11
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhino (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 19:36 EDT by Peter F. Patel-Schneider
Modified: 2009-06-17 19:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 19:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter F. Patel-Schneider 2009-06-17 19:36:23 EDT
Description of problem:

I'm getting a missing dependency when updating rhino.

Version-Release number of selected component (if applicable):

Going to 1.7 0.6.r2.fc11

How reproducible:

Always

Steps to Reproduce:
1. try to update rhino using yum
2.
3.
  
Actual results:


idefix 63> sudo yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rhino.noarch 0:1.7-0.6.r2.fc11 set to be updated
--> Processing Dependency: jline for package: rhino-1.7-0.6.r2.fc11.noarch
--> Finished Dependency Resolution
rhino-1.7-0.6.r2.fc11.noarch from updates has depsolving problems
  --> Missing Dependency: jline is needed by package rhino-1.7-0.6.r2.fc11.noarch (updates)
Error: Missing Dependency: jline is needed by package rhino-1.7-0.6.r2.fc11.noarch (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Expected results:

Update works.

Additional info:

idefix 64> sudo yum info rhino
[sudo] password for pfps: 
Loaded plugins: refresh-packagekit
Installed Packages
Name       : rhino
Arch       : noarch
Version    : 1.7
Release    : 0.5.r2pre.1.1.fc11
Size       : 803 k
Repo       : installed
Summary    : JavaScript for Java
URL        : http://www.mozilla.org/rhino/
License    : MPLv1.1 or GPLv2+
Description: Rhino is an open-source implementation of JavaScript written
           : entirely in Java. It is typically embedded into Java applications
           : to provide scripting to end users.

Available Packages
Name       : rhino
Arch       : noarch
Version    : 1.7
Release    : 0.6.r2.fc11
Size       : 776 k
Repo       : updates
Summary    : JavaScript for Java
URL        : http://www.mozilla.org/rhino/
License    : MPLv1.1 or GPLv2+
Description: Rhino is an open-source implementation of JavaScript written
           : entirely in Java. It is typically embedded into Java applications
           : to provide scripting to end users.

idefix 65> sudo yum info jline
Loaded plugins: refresh-packagekit
Error: No matching Packages to list
idefix 66> sudo yum install jline
Loaded plugins: refresh-packagekit
Setting up Install Process
No package jline available.
Nothing to do
Comment 1 Peter F. Patel-Schneider 2009-06-17 19:39:59 EDT
Please ignore this "bug".  I realized that I didn't have the fedora 11 repository enabled.

Sorry for the inconvenience.

Note You need to log in before you can comment on or make changes to this bug.