Bug 506640 - Problem with yum-plugin-downloadonly
Problem with yum-plugin-downloadonly
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
11
i386 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 509525 528187 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 23:31 EDT by Eugen O
Modified: 2014-01-21 18:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 12:00:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugen O 2009-06-17 23:31:41 EDT
Description of problem:

Python traceback when trying to use yum-plugin-downloadonly.
 
Version-Release number of selected component (if applicable):
FC 11 i386.

How reproducible:
Install the plugin via yum and then try to download a file.

Steps to Reproduce:
1. yum install yum-plugin-downloadonly 
2. yum install mc --downloadonly --downloaddir=/root
  
Actual results:

[root@localhost log]# yum reinstall mc --downloadonly --downloaddir=/root   
Loaded plugins: dellsysidplugin2, downloadonly, refresh-packagekit
Setting up Reinstall Process
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 309, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 178, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 352, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 1010, in doCommand
    return base.reinstallPkgs(extcmds)
  File "/usr/share/yum-cli/cli.py", line 680, in reinstallPkgs
    oldcount = len(self.tsInfo)
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 658, in <lambda>
    tsInfo = property(fget=lambda self: self._getTsInfo(), 
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 112, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 649, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 491, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 232, in populateSack
    self.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 79, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 180, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/downloadonly.py", line 41, in postreposetup_hook
    repo.setAttribute('pkgdir',opts.dldir)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 295, in setAttribute
    setattr(self, key, value)
AttributeError: can't set attribute


Expected results:

It should download the mc rpm into /root directory.

Additional info:

I using : 
yum-3.2.23-3.fc11.noarch
yum-plugin-downloadonly-1.1.22-1.fc11.noarch
Comment 1 James Antill 2009-06-18 13:15:11 EDT
It's the --downloaddir option which is broken, I've fixed this upstream.
Comment 2 Liam Li 2009-07-03 06:14:22 EDT
*** Bug 509525 has been marked as a duplicate of this bug. ***
Comment 3 James Antill 2009-10-09 11:54:33 EDT
*** Bug 528187 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.