Bug 506657 - (fuzzy-shot) Bad screen capture on Intel GPU
Bad screen capture on Intel GPU
Status: CLOSED DUPLICATE of bug 503820
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 03:52 EDT by Luya Tshimbalanga
Modified: 2009-06-18 15:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-18 15:37:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fuzzy screen capture (150.32 KB, image/png)
2009-06-18 03:52 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2009-06-18 03:52:03 EDT
Created attachment 348389 [details]
Fuzzy screen capture

Description of problem:
Capturing a desktop generate a bad picture

Version-Release number of selected component (if applicable):
 2.7.0-7

How reproducible:
Always

Steps to Reproduce:
1. Simply do a desktop screenshot. Fn+Prt Sc
2.
3.
  
Actual results:
Fuzzy screenshot

Expected results:
Clean screenshot

Additional info:
Used LG LT20 (Intel GPU 8225) and faulty screenshot included
Comment 1 Matěj Cepl 2009-06-18 08:01:57 EDT
Are you able to reproduce it even when you upgrade xorg-x11-server*, xorg-x11-drv-intel, kernel, mesa*, libdrm*, libdri* to the latest versions from koji?
Comment 2 Kristian Høgsberg 2009-06-18 10:36:18 EDT
We still have screenshot problems for i8xx type intel hardware.  There's no such thing as an Intel GPU 8225, so I'd like to see either output of lspci -nn or the Xorg.0.log file.  I'm guessing it's an 845, 855 or 865 and a then this is a dupe of #503820.
Comment 3 Luya Tshimbalanga 2009-06-18 14:46:25 EDT
$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3580] (rev 02)
00:00.1 System peripheral [0880]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3584] (rev 02)
00:00.3 System peripheral [0880]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3585] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
00:02.1 Display controller [0380]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)

My bad, the GPU is Intel 82852/855GM. I have updated both xorg-x11-xserver and mesa to the latest version (1.6.1.901-5 and 7.6.0-2 respectively) with same result. Since the bug appears to be a dupe, you can close it.
Comment 4 Luya Tshimbalanga 2009-06-18 15:37:52 EDT

*** This bug has been marked as a duplicate of bug 503820 ***

Note You need to log in before you can comment on or make changes to this bug.