Bug 506667 - .ogg video file displays abnormally in totem.
.ogg video file displays abnormally in totem.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libtheora (Show other bugs)
5.3
s390x Linux
low Severity medium
: rc
: ---
Assigned To: Jindrich Novy
desktop-bugs@redhat.com
:
: 507662 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 04:47 EDT by XinSun
Modified: 2013-07-02 19:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-26 05:30:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Face-mosaic.png (59.59 KB, image/png)
2009-06-18 04:47 EDT, XinSun
no flags Details
Face-screen.png (147.19 KB, image/png)
2009-06-18 04:56 EDT, XinSun
no flags Details

  None (edit)
Description XinSun 2009-06-18 04:47:20 EDT
Created attachment 348390 [details]
Face-mosaic.png

Description of problem:
When display Face.ogg file in totem on s390x platform, video file displays abnormally.

Version-Release number of selected component (if applicable):
totem-2.16.7-6.el5

How reproducible:
Always

Steps to Reproduce:
1.Launch totem.
2.Download Face.ogg from http://pfrields.fedorapeople.org/screencasts/
3.Open Face.ogg in totem.
  
Actual results:
Face.ogg file displays green mosaic.Please see the attachment:Face-mosaic.png

Expected results:
totem can display Face.ogg file normally.Please see the attachment: Face-screen.png.

Additional info:
Face.ogg file can display normally on other platform (e.g. x86, i386, ppc, ia64).
Comment 1 XinSun 2009-06-18 04:56:34 EDT
Created attachment 348396 [details]
Face-screen.png
Comment 2 Bastien Nocera 2009-06-18 05:04:09 EDT
Does this work:
gst-launch playbin uri=http://pfrields.fedorapeople.org/screencasts/Face.ogg
?

If it doesn't, then it's a problem with GStreamer or the Theora/Ogg libraries.
Comment 3 XinSun 2009-06-18 05:49:26 EDT
After run gst-launch play bin command, the result is:

.qa.[root@s390x-5s-v1 ~]# gst-launch playbin uri=http://pfrields.fedorapeople.org/screencasts/Face.ogg
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /audiosink-actual-sink-alsa: Could not open audio device for playback.
Additional debug info:
gstalsasink.c(697): gst_alsasink_open (): /audiosink-actual-sink-alsa:
Playback open error on device 'default': No such file or directory
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
FREEING pipeline ...
Comment 4 Bastien Nocera 2009-06-18 05:53:22 EDT
Try this then:
gst-launch playbin uri=http://pfrields.fedorapeople.org/screencasts/Face.ogg current-audio="-1"

What's the point of playing videos on a system without audio btw?
Comment 5 XinSun 2009-06-18 22:11:37 EDT
I try command with current-audio="-1" again, and get the same result:

Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /audiosink-actual-sink-alsa: Could not open audio device
for playback.
Additional debug info:
gstalsasink.c(697): gst_alsasink_open (): /audiosink-actual-sink-alsa:
Playback open error on device 'default': No such file or directory
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
FREEING pipeline ...
Comment 6 Bastien Nocera 2009-06-23 13:26:56 EDT
*** Bug 507662 has been marked as a duplicate of this bug. ***
Comment 7 Bastien Nocera 2009-06-23 13:27:47 EDT
Bug 507662 has a backtrace.
Comment 8 Jindrich Novy 2009-11-20 08:35:12 EST
Backtrace without debuginfo installed is useless in order to find a source of failure. Could you please install libtheora-devel and provide backtrace again?

Thanks.
Comment 9 XinSun 2009-11-22 23:07:46 EST
Tested on rhel5.4 with totem-2.16.7-6.el5
After installing libtheora-devel package, the output of backtrace are as follows:
Program received signal SIGINT, Interrupt.
0x0000004db6808d3a in poll () from /lib64/libc.so.6
(gdb) bt
#0  0x0000004db6808d3a in poll () from /lib64/libc.so.6
#1  0x0000004d2f8216c6 in ?? () from /lib64/libglib-2.0.so.0
#2  0x0000004d2f821cde in g_main_loop_run () from /lib64/libglib-2.0.so.0
#3  0x000002000034e2a6 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#4  0x00000000800275a4 in main (argc=0, argv=0x3ffffd11680) at totem.c:3810

The packages have installed are :
totem-2.16.7-6.el5.s390x
totem-mozplugin-2.16.7-6.el5.s390x
totem-debuginfo-2.16.7-6.el5.s390x
totem-devel-2.16.7-6.el5.s390x
totem-2.16.7-6.el5.s390
totem-mozplugin-2.16.7-6.el5.s390
totem-debuginfo-2.16.7-6.el5.s390
totem-devel-2.16.7-6.el5.s390
libtheora-devel-1.0alpha7-1.s390
libtheora-devel-1.0alpha7-1.s390x

then run "gst-launch playbin uri=http://pfrields.fedorapeople.org/screencasts/f9/Face.ogg current-audio="-1", output is same with comment #5 
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /audiosink-actual-sink-alsa: Could not open audio device
for playback.
Additional debug info:
gstalsasink.c(697): gst_alsasink_open (): /audiosink-actual-sink-alsa:
Playback open error on device 'default': No such file or directory
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
FREEING pipeline ...
Comment 11 Jan Zeleny 2013-03-26 05:30:48 EDT
Since we are now in Phase 2 of RHEL5 development cycle, this bug will not be addressed, as it is not critical. If you observe this bug in later version of RHEL, please clone the bug for that version. For RHEL5, I'm closing this as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.