Bug 506705 - not aligned "Per-User Subscription Restrictions" checkboxes in "Create Software Channel"
not aligned "Per-User Subscription Restrictions" checkboxes in "Create Softwa...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
wes hayutin
:
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-06-18 08:43 EDT by Jan Hutař
Modified: 2009-09-10 15:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:49:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Per-User Subscription Restrictions" checkboxes in "Create Software Channel" (18.35 KB, image/png)
2009-06-18 08:43 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2009-06-18 08:43:01 EDT
Created attachment 348432 [details]
"Per-User Subscription Restrictions" checkboxes in "Create Software Channel"

Description of problem:
When I accessed "Create Software Channel" form, I see that checkboxes in "Per-User Subscription Restrictions" are not aligned. See attached screenshot. Same problem exists when I want to edit this option.


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090612.0-x86_64


How reproducible:
always (tested in latest Opera)


Steps to Reproduce:
1. create or edit custom channel


Actual results:
see screenshot


Expected results:
correctly aligned


Additional info:
Code there is like this:

            <table>
            <tr>
            <td><input type="radio" name="per_user_subscriptions" value="all" checked="checked"></td>
            <td>All users within your organization may subscribe to this channel.</td>
            </tr><tr>
            <td><input type="radio" name="per_user_subscriptions" value="selected"></td>
            <rhn-require 
            <td>Only selected users within your organization may subscribe to this channel.</td>
            </tr>
            </table>

So I guess it is because of that "<rhn-require" (?).
Comment 1 Brad Buckingham 2009-06-18 11:33:13 EDT
Just out of curiousity what browser & version are you using?

I do see the syntax error mentioned above in the code and that should be fixed; however, w/ Firefox 3.0.7, I don't see the misalignment.  (Just curious so that once change is made can actually verify chgs fix the problem).
Comment 2 Shannon Hughes 2009-06-18 12:23:02 EDT
i don't see the issue either in my firefox but i am betting the rhn require issue is throwing it off for some versions. i removed the invalid tag. give it another try and let us know. 

btw, my ff version is 3.0.11
Comment 3 Jan Hutař 2009-06-19 05:14:08 EDT
Well, it is Opera: opera-9.64-2480.gcc4.shared.qt3.x86_64

Anyway, tester should be able to verify that part of the code is sane after the fix.

Thank you,
Jan
Comment 4 Shannon Hughes 2009-06-19 11:49:16 EDT
mass move to onqa
Comment 5 wes hayutin 2009-06-23 13:35:42 EDT
verified 6/19
Comment 6 Brad Buckingham 2009-07-31 11:39:33 EDT
the 2 columns appear to be aligned properly with 7/24 stage iso... moving to RELEASE_PENDING
Comment 7 Brandon Perkins 2009-09-10 15:49:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.