Bug 506708 - brother hl-1430 printer is unable to print
brother hl-1430 printer is unable to print
Status: CLOSED DUPLICATE of bug 513667
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 08:56 EDT by cornel panceac
Modified: 2009-08-21 04:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 04:53:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foomatic-rip.ps (774.95 KB, application/postscript)
2009-06-18 08:59 EDT, cornel panceac
no flags Details
foomatic-rip.log (36.47 KB, text/x-log)
2009-06-18 09:00 EDT, cornel panceac
no flags Details

  None (edit)
Description cornel panceac 2009-06-18 08:56:51 EDT
Description of problem:
in fedora 11 i'm no longer able to print on brother hl-1430 printer.

Version-Release number of selected component (if applicable):
$ rpm -q cups
cups-1.4-0.b2.18.fc11.i586


How reproducible:
always

Steps to Reproduce:
1.try to print anything
2.
3.
  
Actual results:
printer warms but nothing is printed

Expected results:


Additional info:
Comment 1 cornel panceac 2009-06-18 08:59:31 EDT
Created attachment 348434 [details]
foomatic-rip.ps
Comment 2 cornel panceac 2009-06-18 09:00:41 EDT
Created attachment 348435 [details]
foomatic-rip.log
Comment 3 Tim Waugh 2009-06-18 13:08:35 EDT
Did it work in Fedora 10?
Comment 4 cornel panceac 2009-06-18 13:12:57 EDT
worked perfectly. it's still working on windows xp, on same computer (and another one).
Comment 5 Tim Waugh 2009-06-19 06:21:10 EDT
So the 'Brother HL-1430 Foomatic/gutenprint-ijs-simplified.5.2' driver fails in Fedora 11.  Let's try the native CUPS gutenprint driver to eliminate foomatic from the equation.

Select System->Administration->Printing, double-click on HL-1430-series and click on the 'Change...' button next to the 'Make and Model' label.

Now select a driver that says 'Brother HL-1430 CUPS+Gutenprint v5.2.3 Simplified' and click Forward, then Apply.

Finally, print a test page -- does that give any better result?

If that fails, please try the driver named 'Brother HL-1430 Foomatic/hl1250' (this one was the default driver in Fedora 10).

If that still fails, try the others.

Let me know which driver gives the best results.
Comment 6 Josep 2009-06-19 10:28:39 EDT
Same problem here. I tried the suggestions in comment #5, and here I my results:

* gutenprint-ijs-simplified.5.2: doesn't print, the "data LED" blinks for a while, but then it stops and nothing is printed. This was the default driver selected, by the way.
* gutenprint-ijs.5.2: same as previous one.
* hpijs: works.
* hl1250: reports printer as stopped.
* lj4dith: does not work, the printer does feed a paper but nothing is printed on it.
* ljet4: same lj4dith.

Briefly: hpijs is the only driver that works, the rest don't.
It's strange that the hl1250 doesn't work as it was the one I used to have configured in F10.
Comment 7 Tim Waugh 2009-07-03 06:59:08 EDT
I think the reason the hl1250 driver wasn't working was foomatic: see bug #496521.  Perhaps you could try the "test update" foomatic package (4.0.2-3.fc11) and report whether the hl1250 driver works once again?

http://koji.fedoraproject.org/koji/buildinfo?buildID=112804
Comment 8 cornel panceac 2009-07-15 03:49:03 EDT
ok, i was three weeks in holiday so now, back to office, i can confirm the report from #6.

i will download from koji and report more.
Comment 9 cornel panceac 2009-07-15 04:24:35 EDT
ok, with foomatic 4.0.2-3.fc11.i586, hl1250 works, hpijs works, ljet4 "prints" a blank page as before, and the others (guten*{simplified}* and lj4dith) send data but nothing gets printed.

thank you.
Comment 10 Tim Waugh 2009-07-15 09:05:55 EDT
Great.  So the only remaining problem is that foomatic thinks those other drivers are able to work with this device.
Comment 11 Tim Waugh 2009-08-21 04:53:36 EDT
This is essentially the same as bug #513667.

*** This bug has been marked as a duplicate of bug 513667 ***

Note You need to log in before you can comment on or make changes to this bug.