Bug 506729 - SAF Test lck: saLckResourceClose/3-2
SAF Test lck: saLckResourceClose/3-2
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openais (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ryan O'Hara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 10:04 EDT by Jan Friesse
Modified: 2009-06-29 17:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 17:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Main program (5.60 KB, text/x-csrc)
2009-06-18 10:04 EDT, Jan Friesse
no flags Details
3-2-fork.c (4.23 KB, text/x-csrc)
2009-06-18 10:05 EDT, Jan Friesse
no flags Details
New saLckResourceClose/3-2.c test case. (5.88 KB, text/x-csrc)
2009-06-29 17:55 EDT, Ryan O'Hara
no flags Details

  None (edit)
Description Jan Friesse 2009-06-18 10:04:16 EDT
Created attachment 348470 [details]
Main program

Description of problem:
SUBJ Fail

Version-Release number of selected component (if applicable):
TRUNK

How reproducible:
Compile and run included files

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Fail

Expected results:
Pass

Additional info:
Again nice select, so

Call the api to test if the pending request is dropped,when the requestor
   has a pending EX mode lock request against the lock resource.
   Test steps:
    1. open a resource to lock.
    2. fork a child process , in the child process ,to lock the resource
      using PR lock,and then send a signal SIGUSR1 to father process,and
      then pause.
    3. father process lock the same resource using
      EX lock, and then close the resource,and then test if the pending
      request is dropped.
    4. father process send a signal to child process,let it go on and
       return.
    5. father wait for child process' terminal.
   Return = SA_AIS_OK
   3-fork.c is the child process.

For me, it looks like good test
Comment 1 Jan Friesse 2009-06-18 10:05:34 EDT
Created attachment 348471 [details]
3-2-fork.c

Child of main program
Comment 2 Ryan O'Hara 2009-06-29 17:55:13 EDT
Created attachment 349882 [details]
New saLckResourceClose/3-2.c test case.

Here is a new version of saLckResourceClose/3-2.c that does not use select to
determine is a callback has been made.
Comment 3 Ryan O'Hara 2009-06-29 17:55:49 EDT
Closing this as fixed upstream. OpenAIS lock service now has code to
cancel/skip callbacks for resources that have been closed with pending
callbacks. Fix for saftest code it attached above.

Note You need to log in before you can comment on or make changes to this bug.