Bug 506732 - "System Sounds" volume setting "breaks" or "lowers" all sound levels
"System Sounds" volume setting "breaks" or "lowers" all sound levels
Status: CLOSED DUPLICATE of bug 505610
Product: Fedora
Classification: Fedora
Component: libcanberra (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 10:15 EDT by Tom London
Modified: 2009-07-09 00:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-09 00:38:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2009-06-18 10:15:26 EDT
Description of problem:
I noticed that each time I logged in, the volume setting was being reset to 0% (i.e., I was getting a red x on the volume applet).  Setting this to something more reasonable, say 100%, would restore sound to the current session, but it would return to 0% the next time I logged in.

After "fiddling" for a while, I noticed that I also had "lost" the "system start" sound on login.

I changed the setting for "sound effects" to something other than 0%, logged out and back in, and I got both the "system start" sound as well as a non-zero volume level for my apps.

In addition, I noticed that if the sound effects level was set to something other than 100%, each time I logged in, the system sound level got lower and lower (83% the first time, about 65% the second, ...)

Is there some "deadly dance" here?

Version-Release number of selected component (if applicable):
libcanberra-0.12-2.fc12.x86_64

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lennart Poettering 2009-07-01 08:20:43 EDT
Does this still happen with PA 0.9.15-14?
Comment 2 Tom London 2009-07-01 17:51:18 EDT
Yes, this is still broken with:

pulseaudio-utils-0.9.16-1.test1.fc12.x86_64
pulseaudio-module-bluetooth-0.9.16-1.test1.fc12.x86_64
pulseaudio-module-x11-0.9.16-1.test1.fc12.x86_64
pulseaudio-libs-0.9.16-1.test1.fc12.x86_64
pulseaudio-0.9.16-1.test1.fc12.x86_64
pulseaudio-debuginfo-0.9.16-1.test1.fc12.x86_64
pulseaudio-module-gconf-0.9.16-1.test1.fc12.x86_64
pulseaudio-libs-glib2-0.9.16-1.test1.fc12.x86_64


Here is how I tested this:

1. I had my "usual" setup with the system-wide volume set at 95% and the "Alert Volume" slider set at 100%.
2. Logging in plays a nice loud "login sound", and the system-wide volume (as displayed by putting the cursor over the volume applet) remains at 95%.
3. I reset the "Alert Volume" slider to about 50% and reboot.
4. Logging in again, I get a much quieter "login sound", and the system-wide volume now says 45%.

I'm guessing, but it appears that some code is multiplying the system-side volume with the "Alert Sound" setting percentage and getting 45%.
Comment 3 Tom London 2009-07-01 17:52:15 EDT
Sorry, adding libcanberra version:

libcanberra-0.13-1.fc12.x86_64
libcanberra-gtk2-0.13-1.fc12.x86_64
libcanberra-debuginfo-0.13-1.fc12.x86_64
Comment 4 Matthias Clasen 2009-07-09 00:38:30 EDT
This is actuall a libvorbis bug, it seems

*** This bug has been marked as a duplicate of bug 505610 ***

Note You need to log in before you can comment on or make changes to this bug.