Bug 506741 - Upgrade perl threads
Upgrade perl threads
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
: EasyFix, Reopened
: 507570 (view as bug list)
Depends On:
Blocks: 516996
  Show dependency treegraph
 
Reported: 2009-06-18 10:34 EDT by Oliver Falk
Modified: 2009-12-03 11:19 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 11:19:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2009-06-18 10:34:22 EDT
Current version of threads includes a very old (and very buggy) version of threads::shared.
The other option would be to provide a separate package (eg. perl-threads).
Comment 1 Oliver Falk 2009-06-18 10:35:35 EDT
Of course not only true for F10. It would be nice to have it for F11 and rawhide as well...
Comment 2 Marcela Mašláňová 2009-06-19 03:20:04 EDT
I'd rather update the rawhide version of threads in core package. In F-10 and F-11 this could be done (maybe) by separate package. Stepan?
Comment 4 Marcela Mašláňová 2009-08-18 08:43:04 EDT
In perl-5.10.1-RC1 are the latest threads. Maybe the update is useless and we can wait for update to the 5.10.1 when it will be ready.
Comment 6 Bug Zapper 2009-11-18 07:06:34 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Marcela Mašláňová 2009-11-18 07:12:11 EST
Thread will be updated in rawhide.
Comment 8 Marcela Mašláňová 2009-12-03 02:28:17 EST
*** Bug 507570 has been marked as a duplicate of this bug. ***
Comment 9 Stepan Kasal 2009-12-03 11:19:42 EST
perl-5.10.1-101.fc13 has been just built and should appear in rawhide tomorrow.

Note You need to log in before you can comment on or make changes to this bug.