Bug 50677 - wrong line of script for /etc/profile.d/krb5.csh
wrong line of script for /etc/profile.d/krb5.csh
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
7.1k
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 20:07 EDT by Kin Yip
Modified: 2007-04-18 12:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.5-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 15:11:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kin Yip 2001-08-01 20:07:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Hello,

After I installed the kerberos in my Linux, I  have 
krb5.csh in /etc/profile.d .  It has the following line :

if ( /usr/kerberos/bin !~ "${path}" ) then
        set path = (  $path /usr/kerberos/bin )
endif

The logic after "if" doesn't seem to work.   It's supposed to check
whether "/usr/kerberos/bin"  is defined.  If not, it'd add to it.  But 
the above just doesn't work.

It should be really  for example :

if ( "${path}" !~  {*/usr/kerberos/bin*} ) then
        set path = (  $path /usr/kerberos/bin )
endif

I have tested it in tcsh and csh environments and in many Linux systems
in Labs. such as Fermilab and BNL in US and CERN in Switzerland.
My suggested script would work but not yours.

Kin

How reproducible:
Always

Steps to Reproduce:
1.  Say, do 
	
if ( /usr/kerberos/bin !~ "${path}" )  echo hi



Actual Results:  Even though you already have /usr/kerberos/bin in your
$path, you'd still 

hi

in return.

Expected Results:  But you shouldn't have anything in return !

Additional info:

It should be something like :

if ( "${path}"  !~ {*/usr/kerberos/bin*} )  echo hi
Comment 1 Need Real Name 2002-03-26 02:18:32 EST
Hallo,
Addtional, this bug is inclosed in Redhat 7.2, rpm-package
krb-workstation-1.2.2-13 .
This is bad, because the variable PATH is prolonged recursiv!

Comment 2 C. Ray Ng 2003-01-29 12:55:54 EST
It was fixed on RH8, krb5-workstation-1.2.5-7, build date Wed 23 Oct 2002.

But on RH7.3 or older, krb5-workstation-1.2.4-3, build date Wed 23 Oct 2002,
is still come with this problem.
Comment 3 Bill Nottingham 2006-08-07 14:57:28 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.

Note You need to log in before you can comment on or make changes to this bug.