This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 506774 - system-config-display error in F11
system-config-display error in F11
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
11
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 11:59 EDT by Kurt Bechstein
Modified: 2009-12-18 09:46 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-08 16:24:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg config file (1.50 KB, text/plain)
2009-06-18 11:59 EDT, Kurt Bechstein
no flags Details

  None (edit)
Description Kurt Bechstein 2009-06-18 11:59:29 EDT
Created attachment 348510 [details]
xorg config file

Description of problem:

I have a newly installed F11 system with system-config-display-1.1.3-2.fc11.noarch installed on the system.  When I run the program i get the following error:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 376, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 665, in __init__
    self.xml.get_widget("secondMonitorLabel").set_text(monitor_list[1].modelname)
TypeError: GtkLabel.set_text() argument 1 must be string, not None

I get this with the attached xorg.conf or without it as well.  This system is a Dell Latitude D830 with Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller.


How reproducible:  Every time


Steps to Reproduce:
1.Run system-config-display as root.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 dominique 2009-07-31 13:22:05 EDT
I have the same problem, I have installed F11 and system-config-display-1.1.3-2.fc11.noarch and when I want running system-config-display I have this error message:

[root@localhost ~]# system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 376, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 641, in __init__
    if len(self.xconfig.layout[0].adjacencies) > 1:
IndexError: index out-of-bounds

I also test the rawhide an I have same problem with same error message
Comment 2 Andre Robatino 2009-08-04 16:46:17 EDT
This looks like a duplicate of bug #506432.
Comment 3 Matěj Cepl 2009-11-05 13:32:36 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 4 dominique 2009-11-05 15:40:24 EST
I upgrade my F11 with updates-testing packages for same error messages.

But I also test rawhide, with the last update, and system-config-display work fine.
Comment 5 Matěj Cepl 2009-11-08 16:24:18 EST
Thank you for letting us know.
Comment 6 Andre Robatino 2009-11-15 09:44:35 EST
Bug still exists in F12 (AKA RC4).  It only started manifesting after installing akmod-nvidia from rpmfusion repo.  It was the same with F11.  Please reopen.
Comment 7 dominique 2009-11-15 11:36:09 EST
I confirm comment #6
With F12 and akmod-nvidia installed, I have this error when I launch system-config-display:

[root@localhost ~]# system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 378, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig, videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 640, in __init__
    if len(self.xconfig.layout[0].adjacencies) > 1:
IndexError: index out-of-bounds

But it's strange because with rawhide and the same akmod-nvidia, system-config-display worked (see post #4).
Comment 8 leigh scott 2009-12-18 09:46:43 EST
You are getting this error because xorg.conf already exists.


Try

su
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.test


now try system-config-display as non-root


/usr/bin/system-config-display

Note You need to log in before you can comment on or make changes to this bug.