Bug 506791 - xfigs spellchecking doesn't work. easy-fix
xfigs spellchecking doesn't work. easy-fix
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfig (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Stepan Kasal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 12:48 EDT by Caolan McNamara
Modified: 2009-06-28 05:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 05:19:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Caolan McNamara 2009-06-18 12:48:36 EDT
Description of problem:

Fedora's xfig has its spellchecking command customized to "aspell %f", but "aspell %f" doesn't output the misspellings in the format that xfig needs.


Version-Release number of selected component (if applicable):
xfig-3.2.5-20.a.fc11.i586

How reproducible:
100%

Steps to Reproduce:
1. Click Text tool, click in canvas area
2. Type a misspelling, e.g. applp
3. click somewhere else in canvas area
4. edit->spell check
  
Actual results:
"No misspellings found"

Expected results:
find the misspelling

Additional info:

The fix is trivial, the best thing to do given https://fedoraproject.org/wiki/Features/Dictionary is to change
xfig-3.2.5a-default-apps.patch
from "aspell %f" to "enchant -l %f" and change the 
"Requires: aspell"
to a
"Requires: enchant"
Comment 1 Caolan McNamara 2009-06-18 12:50:23 EDT
oh, and xfig-3.2.4-redhat.patch isn't applied in that .spec either, probably can delete it, xfig-3.2.5a-default-apps.patch seems to have replaced it
Comment 2 Caolan McNamara 2009-06-28 05:19:46 EDT
fixed it up myself on a "It's easier to ask forgiveness than it is to get permission." basis as xfig-3.2.5-21.a.fc12
Comment 3 Hans de Goede 2009-06-28 05:27:14 EDT
(In reply to comment #2)
> fixed it up myself on a "It's easier to ask forgiveness than it is to get
> permission." basis as xfig-3.2.5-21.a.fc12  

Great, thanks! Actually feel free to fix anything with any of my packages when you encounter it.

Note You need to log in before you can comment on or make changes to this bug.