Bug 506793 - expectk error "Application initialization failed: version conflict for package "Tcl": have 8.5.6, need exactly 8.5"
expectk error "Application initialization failed: version conflict for packag...
Status: CLOSED DUPLICATE of bug 456738
Product: Fedora
Classification: Fedora
Component: expect (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 12:54 EDT by robert.jacobs
Modified: 2009-06-24 09:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 09:17:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description robert.jacobs 2009-06-18 12:54:43 EDT
Description of problem:
expectk generates error message when running
Application initialization failed: version conflict for package "Tcl": have 8.5.6, need exactly 8.5

Version-Release number of selected component (if applicable):
expectk-5.43.0-17.fc11.x86_64
tcl-8.5.6-6.fc11.x86_64
tk-8.5.6-4.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. expectk
2.
3.
  
Actual results:
Application initialization failed: version conflict for package "Tcl": have 8.5.6, need exactly 8.5
%

Expected results:
%

Additional info: I have only installed products using the Fedora 11 tree. 
The add/remove software for Fedora 11 repositories does not list Tcl 8.5 as an available product to install, even if I turn off "show latest version". Having Tcl/Tk version 8.5 in the repository would be enough for me to say that this bug is closed.

If expectk requires exactly 8.5, then the rpm that checks for dependencies should also check this.
Comment 1 Vitezslav Crhonek 2009-06-24 09:17:41 EDT

*** This bug has been marked as a duplicate of bug 456738 ***

Note You need to log in before you can comment on or make changes to this bug.