Bug 506842 - black screen
black screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 17:10 EDT by Paul Lange
Modified: 2009-10-08 18:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-08 18:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (55.95 KB, application/octet-stream)
2009-06-21 16:23 EDT, Paul Lange
no flags Details
messages log file (70.78 KB, application/octet-stream)
2009-06-21 16:26 EDT, Paul Lange
no flags Details

  None (edit)
Description Paul Lange 2009-06-18 17:10:04 EDT
Description of problem:
When watching movies with totem sometimes the screen becomes black and there is no way (as far as I know) to get it back to showing an image and I have to restart hard.
I enabled KMS.

Version-Release number of selected component (if applicable):
36.20090514git9656762.fc11


If you need more info please tell me how I can get it.

From the syslog (last entries before I restarted):
Jun 18 16:51:38 papaya kernel: CE: hpet increasing min_delta_ns to 33750 nsec
Jun 18 16:52:06 papaya pulseaudio[2231]: alsa-sink.c: Increasing wakeup watermark to 50,00 ms
Jun 18 16:55:13 papaya pulseaudio[2231]: alsa-sink.c: ALSA woke us up to write new data to the device, but there was actually nothing to write!
Jun 18 16:55:13 papaya pulseaudio[2231]: alsa-sink.c: Most likely this is a bug in the ALSA driver 'snd_hda_intel'. Please report this issue to the ALSA developers.
Jun 18 16:55:13 papaya pulseaudio[2231]: alsa-sink.c: We were woken up with POLLOUT set -- however a subsequent snd_pcm_avail() returned 0 or another value < min_avail.
Jun 18 16:57:42 papaya ntpd[1856]: synchronized to 146.83.183.179, stratum 2
Jun 18 16:59:30 papaya pulseaudio[2231]: ratelimit.c: 2 events suppressed
Jun 18 16:59:30 papaya pulseaudio[2231]: alsa-sink.c: Increasing wakeup watermark to 60,00 ms
Jun 18 16:59:34 papaya kernel: nouveau 0000:01:00.0: timeout: SOR_DPMS_STATE_WAIT(0) == 0
Jun 18 16:59:34 papaya kernel: nouveau 0000:01:00.0: SOR_DPMS_STATE(0) = 0x100c8800
Jun 18 16:59:34 papaya pulseaudio[2231]: alsa-sink.c: Increasing wakeup watermark to 70,00 ms
Jun 18 16:59:35 papaya pulseaudio[2231]: alsa-sink.c: Increasing wakeup watermark to 80,00 ms
Comment 1 Ben Skeggs 2009-06-18 18:03:27 EDT
After this happens again, can you boot to text mode (append "3" to your boot options) and take a copy of both /var/log/messages and /var/log/Xorg.0.log.

Thanks!
Comment 2 Paul Lange 2009-06-21 16:23:45 EDT
Created attachment 348815 [details]
Xorg log file
Comment 3 Paul Lange 2009-06-21 16:26:03 EDT
Created attachment 348816 [details]
messages log file

around line 107 is before the screen became black.
Comment 4 Paul Lange 2009-06-21 16:44:44 EDT
Strange, didn't happen the last 3 days, and now 2 times in 20 minutes.

from messages:

Jun 21 16:28:34 papaya kernel: __ratelimit: 64 callbacks suppressed
Jun 21 16:28:34 papaya kernel: totem-video-thu[3982]: segfault at 800000e8 ip 025741e0 sp 01b4ed00 error 4 in libavcodec.so.52.20.0[22d0000+547000]
Jun 21 16:35:16 papaya ntpd[1794]: synchronized to 200.89.74.17, stratum 2
Jun 21 16:36:27 papaya kernel: nouveau 0000:01:00.0: timeout: SOR_DPMS_STATE_WAIT(0) == 0
Jun 21 16:36:27 papaya kernel: nouveau 0000:01:00.0: SOR_DPMS_STATE(0) = 0x100c8800


seems like the video thumbnailer does something wrong. 
I was watching some videos on vimeo and looked for the cached version in the /tmp folder - and suddenly the screen becomes black.
Comment 5 Paul Lange 2009-06-22 14:39:41 EDT
next occurence:

Jun 22 14:30:40 papaya kernel: nouveau 0000:01:00.0: timeout: SOR_DPMS_STATE_WAIT(0) == 0
Jun 22 14:30:40 papaya kernel: nouveau 0000:01:00.0: SOR_DPMS_STATE(0) = 0x100c8800
Comment 6 Paul Lange 2009-10-08 06:14:06 EDT
Seems to be fixed with an update. This behavior didn't occur for at least 3 month now.
Should we close this bug?
Comment 7 Ben Skeggs 2009-10-08 18:21:12 EDT
Thanks for the update, will close!

Note You need to log in before you can comment on or make changes to this bug.