Bug 506846 - hb_gui won't let me add a group resource
hb_gui won't let me add a group resource
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: heartbeat (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 17:16 EDT by Kanwar Ranbir Sandhu
Modified: 2009-09-16 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 19:25:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kanwar Ranbir Sandhu 2009-06-18 17:16:45 EDT
Description of problem:
I'm running heartbeat on a CentOS 5.3 box.  I'm trying to manage heartbeat with hb_gui running on a Fedora 11 desktop.  I can connect to either one of the heartbeat servers, and get a list of the currently configured resources, etc. (at the moment, only the ping nodes and the two servers themselves are visible).

When I use hb_gui to add a new group under "Resources", the group doesn't get added.  Additionally, if hb_gui is run from a gnome terminal, I see this output:

Traceback (most recent call last):
  File "/usr/bin/hb_gui", line 2253, in on_add_item
    dlg.run()
  File "/usr/bin/hb_gui", line 1546, in run
    self.update_param_list()
  File "/usr/bin/hb_gui", line 1387, in update_param_list
    _("Add Parameter"), "nvpair", meta)
  File "/usr/bin/hb_gui", line 458, in __init__
    dtd_elem = manager.get_dtd_elem(obj_type)
  File "/usr/bin/hb_gui", line 3128, in get_dtd_elem
    complete_dtd = load_dtd_string(dtd)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/parsers/xmlproc/xmldtd.py", line 894, in load_dtd_string
    dp.parse_string(dtdstr)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/parsers/xmlproc/xmlutils.py", line 139, in parse_string
    self.feed(doc)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/parsers/xmlproc/xmlutils.py", line 299, in feed
    new_data = new_data + self.encoded_data
TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'

Version-Release number of selected component (if applicable):
heartbeat-gui-2.1.4-6.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start hb_gui
2. Login to heartbeat server
3. Right click on "Resources"
4. Select "Add New Item"
5. Change "Item Type" to "group" and click the OK button.
6. Click "OK" to accept the default group config.
  
Actual results:
The "group_" is never added.  The following error is reported:

Traceback (most recent call last):
  File "/usr/bin/hb_gui", line 2253, in on_add_item
    dlg.run()
  File "/usr/bin/hb_gui", line 1546, in run
    self.update_param_list()
  File "/usr/bin/hb_gui", line 1387, in update_param_list
    _("Add Parameter"), "nvpair", meta)
  File "/usr/bin/hb_gui", line 458, in __init__
    dtd_elem = manager.get_dtd_elem(obj_type)
  File "/usr/bin/hb_gui", line 3128, in get_dtd_elem
    complete_dtd = load_dtd_string(dtd)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/parsers/xmlproc/xmldtd.py", line 894, in load_dtd_string
    dp.parse_string(dtdstr)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/parsers/xmlproc/xmlutils.py", line 139, in parse_string
    self.feed(doc)
  File "/usr/lib64/python2.6/site-packages/_xmlplus/parsers/xmlproc/xmlutils.py", line 299, in feed
    new_data = new_data + self.encoded_data
TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'

Expected results:
Resource Group "group_" should be added.

Additional info:
Changing the group name doesn't do anything.  Changing the other options, "order" and "colocation", doesn't change the results either.
Comment 1 Kevin Fenzi 2009-07-19 14:41:46 EDT
Whats the version of hearbeat on the centos side?
Comment 2 Kanwar Ranbir Sandhu 2009-07-19 16:01:52 EDT
(In reply to comment #1)
> Whats the version of hearbeat on the centos side?  

heartbeat-2.1.3-3.el5.centos
Comment 3 Kevin Fenzi 2009-09-09 17:42:36 EDT
This seems to be a change between 2.1.3 and 2.1.4. The hb_gui is somewhat incompatible (as you have found between the two). 

Unfortunately, hb_gui is no longer shipped in 3.0.0 beta versions, so I'm not sure this is going to be fixable. ;( 

As a workaround can you 'ssh -Y centosmachine hb_gui' and run the gui off one of the centos machines so it's compatible? Or alternately, update the centos version to 2.1.4? (which is in EPEL).
Comment 4 Kevin Fenzi 2009-09-16 19:25:23 EDT
I guess I am going to close this out now. 

Hopefully the workarounds work for you.

Note You need to log in before you can comment on or make changes to this bug.