Bug 506857 - xdg-open in xdg-utils expects xprop to be available.
xdg-open in xdg-utils expects xprop to be available.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xdg-utils (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 19:03 EDT by Hal Duston
Modified: 2009-09-13 15:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-13 15:54:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 22355 None None None Never

  None (edit)
Description Hal Duston 2009-06-18 19:03:48 EDT
Description of problem:
xdg-open in xdg-utils expects xprop to be available.

Version-Release number of selected component (if applicable):
xdg-utils-1.0.2-8.20081121cvs.fc11.noarch
mailcap-2.1.29-2.fc11.noarch
htmlview-4.0.0-5.fc11.noarch
elinks-0.12-0.13.pre3.fc11.i586
mutt-1.5.19-5.fc11.i586

How reproducible:
Always.

Steps to Reproduce:
1. Attempt to view an html attachment in mutt or some other text based email client that uses mailcap.
2.
3.
  
Actual results:
usr/bin/xdg-open: line 306: xprop: command not found

Expected results:
No errors.

Additional info:
Calling xprop in the detectDE shell function could redirect stderr to /dev/null to solve this issue
Comment 1 Rex Dieter 2009-06-18 19:56:53 EDT
Right you are.
Comment 2 Hal Duston 2009-06-18 23:13:15 EDT
I did notice that the behaviour has existed in the upstream since at least 1.0.0 released in October of 2006 for what it's worth (I cannot locate a copy of 0.9, released June of 2006 or earlier).  I didn't open a bug on freedesktop as the upstream xdg-utils appears to assume that X is at least installed throughout.  E.g. it only selects from firefox, mozilla, or netscape as browsers. The addition of text mode browsers htmlview, links and lynx looks to be a Red Hat customization.  I don't know if that will generate any pushback, but by all means... ... ...
Comment 3 Rex Dieter 2009-09-13 15:54:00 EDT
Fix pushed upstream, included in rawhide,

* Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.0.2-11.20090913cvs
- 20090913cvs snapshot                                                         
- xdg-open in xdg-utils expects xprop to be available (#506857)

Note You need to log in before you can comment on or make changes to this bug.