Bug 50686 - GNOME can't invoke many KDE applications (e.g., Shisen-sho)
GNOME can't invoke many KDE applications (e.g., Shisen-sho)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-01 23:50 EDT by David A. Wheeler
Modified: 2013-04-02 00:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 09:49:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. Wheeler 2001-08-01 23:50:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
GNOME cannot invoke many KDE applications on my system, which is
an upgraded Red Hat 7.1 system (from 7.0, from 6.2, from 6.1, from 6.0).
For example,  Main Menu (foot)/KDE/Games/Shisen-Sho when selected causes
nothing visible to happen.



How reproducible:
Always

Steps to Reproduce:
1.Start up GNOME.
2,Select Main Menu (foot)/KDE/Games/Shisen-Sho.
3. Nothing visible happens (it should start the game)


Actual Results:  Nothing visible happens.

Expected Results:  (it should start the game)

Additional info:

I believe the problem is the KDE desktop entry files.  I suspect that KDE
is supporting certain "%" entries in KDE desktop enty files that aren't
valid
in the GNOME invoker.  When the GNOME invoker just passes these "%"
entries along, the KDE apps silently fail to work.

When I cd to /usr/share/applnk/Games
I see that kshisen.desktop has this value:
  Exec=kshisen %i %m -caption "%c"

Changing this line to:
 Exec=kshisen

Makes Shisen-sho work fine.
However,  the other KDE applications generally still don't work.

This system has been upgraded several times; perhaps some of these files
are obsolete and shouldn't be the primary ones being used.
Comment 1 Jonathan Blandford 2001-08-03 19:48:21 EDT
Fixed in current gnome-core
Comment 2 masanari iida 2002-11-19 02:01:58 EST
Exactly which version of the GNOME fix this problem?
I don't find errata PRMs for RH7.1 gnome-core.
I want RedHat to fix this problem on RH7.1.
I have confirmed this one is fixed on RH7.2,though.

Regards,
Comment 3 David A. Wheeler 2002-11-19 15:00:32 EST
I can also confirm that this is fixed in Red Hat 7.2 and 8.0.
Thanks!!

Note You need to log in before you can comment on or make changes to this bug.