Bug 506862 - Hashtab Segfault
Hashtab Segfault
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: asterisk (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 19:56 EDT by Thomas Sailer
Modified: 2009-09-25 16:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.6.1.6-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-25 16:09:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Sailer 2009-06-18 19:56:55 EDT
Description of problem:

asterisk crashes relatively frequently with the following backtrace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f5c8c18d910 (LWP 4895)]
ast_hashtab_remove_this_object_nolock (tab=0xb13870, obj=0xb2b100)
    at hashtab.c:814
814                     if (obj == b->object) {
(gdb) bt
#0  ast_hashtab_remove_this_object_nolock (tab=0xb13870, obj=0xb2b100)
    at hashtab.c:814
#1  0x000000000047d19c in ast_hashtab_remove_this_object (tab=0xb13870,
    obj=0xb2b100) at hashtab.c:792
#2  0x00000000004cdf93 in ast_sched_runq (con=<value optimized out>)
    at sched.c:478
#3  0x00007f5c6298b140 in do_monitor (data=<value optimized out>)
    at chan_sip.c:20241
#4  0x00000000004de258 in dummy_start (data=<value optimized out>)
    at utils.c:968
#5  0x00007f5ce6c2986a in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
#6  0x00007f5ce732525d in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

b seems to always be below 1024


Version-Release number of selected component (if applicable):
asterisk-1.6.1-0.23.rc1.fc11.x86_64

How reproducible:
I haven't found a reliable way to trigger this. It seems to be connected with thread creation.
Comment 1 Fedora Update System 2009-09-07 01:13:15 EDT
asterisk-1.6.1.6-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/asterisk-1.6.1.6-1.fc11
Comment 2 Fedora Update System 2009-09-08 21:51:11 EDT
asterisk-1.6.1.6-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update asterisk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9405
Comment 3 Fedora Update System 2009-09-25 16:09:03 EDT
asterisk-1.6.1.6-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.