Bug 506877 - I tried to Resize and Migrate a partition
I tried to Resize and Migrate a partition
Status: CLOSED DUPLICATE of bug 495520
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
anaconda_trace_hash:51f51f83c959d095c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 00:14 EDT by Andrew Jamison
Modified: 2009-08-24 22:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-24 22:46:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (232.35 KB, text/plain)
2009-06-19 00:15 EDT, Andrew Jamison
no flags Details
Attached traceback automatically from anaconda. (113.71 KB, text/plain)
2009-08-01 16:48 EDT, bugchaser
no flags Details

  None (edit)
Description Andrew Jamison 2009-06-19 00:14:56 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.59 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/geometry.py", line 50, in __init__
    self.__geometry = _ped.Geometry(self.device.getPedDevice(), start, length)
  File "/usr/lib/anaconda/storage/devices.py", line 1232, in _computeResize
    length=newLen)
  File "/usr/lib/anaconda/storage/devices.py", line 1021, in _setTargetSize
    (constraint, geometry) = self._computeResize(self.partedPartition)
  File "/usr/lib/anaconda/storage/devices.py", line 464, in <lambda>
    lambda s, v: s._setTargetSize(v),
  File "/usr/lib/anaconda/storage/deviceaction.py", line 239, in __init__
    self.device.targetSize = newsize
  File "/usr/lib/anaconda/iw/partition_dialog_gui.py", line 293, in run
    actions.append(ActionResizeDevice(request, size))
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1119, in editPartition
    actions = parteditor.run()
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1080, in editCB
    self.editPartition(device)
CreateException: Can't have a partition outside the disk!
Comment 1 Andrew Jamison 2009-06-19 00:15:31 EDT
Created attachment 348599 [details]
Attached traceback automatically from anaconda.
Comment 2 bugchaser 2009-08-01 16:48:21 EDT
Created attachment 355894 [details]
Attached traceback automatically from anaconda.
Comment 3 David Cantrell 2009-08-18 22:18:39 EDT
Can you tell me the steps you took during the installation?  What was on the disk before installing and what steps you were doing during partitioning in the installer.
Comment 4 David Cantrell 2009-08-24 22:46:13 EDT

*** This bug has been marked as a duplicate of bug 495520 ***

Note You need to log in before you can comment on or make changes to this bug.