Bug 506894 - Data corrupted after rebuild on RAID1 and RAID10 for second volume.
Data corrupted after rebuild on RAID1 and RAID10 for second volume.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dmraid (Show other bugs)
5.4
All Linux
high Severity high
: rc
: 5.4
Assigned To: Heinz Mauelshagen
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 03:24 EDT by Krzysztof Wojcik
Modified: 2009-07-28 17:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 17:29:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Wojcik 2009-06-19 03:24:50 EDT
Description of problem:
This problem is visible when test on second volume is performed on RAID1 or RAID10.
When rebuild is finished (theoretically with PASS result), checksums of test files created before rebuild, do not equal checksums of files after rebuild. Dmsetup status reports rebuild is finished, but there is something wrong with rebuilded files.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. echo y | dmraid -f isw -C r1d2n1s0-5 --type 1 --size 5G --disk "/dev/sdb /dev/sdc"
    echo y | dmraid -f isw -C r1d2n0s0 --type 1 --disk "/dev/sdb /dev/sdc"
2. dmraid -ay
5. mkfs.ext3 /dev/mapper/isw_ceacbaeigh_r1d2n0s0
    mkdir /mnt/isw_ceacbaeigh_r1d2n0s0
    mount /dev/mapper/isw_ceacbaeigh_r1d2n0s0 /mnt/isw_ceacbaeigh_r1d2n0s0
3. fsck -f -n /dev/mapper/isw_ceacbaeigh_r1d2n0s0
4. openssl rand -out /mnt/isw_ceacbaeigh_r1d2n0s0/r1testFile0.bin 419430400
    md5sum /mnt/isw_ceacbaeigh_r1d2n0s0/r1testFile0.bin | gawk '{print $1}'
    openssl rand -out /mnt/isw_ceacbaeigh_r1d2n0s0/r1testFile1.bin 400000000
    md5sum /mnt/isw_ceacbaeigh_r1d2n0s0/r1testFile1.bin | gawk '{print $1}'
    openssl rand -out /mnt/isw_ceacbaeigh_r1d2n0s0/r1testFile2.bin 1073741824
    md5sum /mnt/isw_ceacbaeigh_r1d2n0s0/r1testFile2.bin | gawk '{print $1}'
5. umount /dev/mapper/isw_ceacbaeigh_r1d2n0s0
    rmdir /mnt/isw_ceacbaeigh_r1d2n0s0
6. REBOOT PC- remove disk from raid
7.dmraid -R isw_ceacbaeigh_r1d2n0s0 "/dev/sdd"
      WAIT UNTILL REBUILD IS FINISHED
8. dmraid -an isw_ceacbaeigh_r1d2n0s0
9. mkdir /mnt/dev
      mount /dev/sdb /mnt/dev
10. md5sum /mnt/dev/r1testFile1.bin | gawk '{print $1}'
       md5sum /mnt/dev/r1testFile2.bin | gawk '{print $1}'
       COMPARE THESE CHECKSUMS WITH CHECKSUMS 
       FROM POINT 7 ABOVE; THEY'RE DIFFERENT

  
Actual results:
Checksums of files created before rebuild don't equal checksums of files after rebuild.

Expected results:
Checksums of files created before rebuild equal checksums of files after rebuild.

Additional info:
Comment 2 Krzysztof Wojcik 2009-07-20 09:30:57 EDT
Issue verified in RHEL5.4 Beta with pass result.
Comment 3 Tom Coughlan 2009-07-21 13:22:03 EDT
(In reply to comment #2)
> Issue verified in RHEL5.4 Beta with pass result.  

So, just to confirm, this BZ can be closed NOTABUG ?
Comment 4 Krzysztof Wojcik 2009-07-22 04:40:21 EDT
Yes you are right. This is not a bug.

Note You need to log in before you can comment on or make changes to this bug.