Bug 506935 - Thunderbird BadWindow when Desktop effects activated
Thunderbird BadWindow when Desktop effects activated
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 07:52 EDT by Didier G
Modified: 2009-10-24 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-19 13:50:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Didier G 2009-06-19 07:52:46 EDT
Description of problem:

Thunderbird fails with BadWindow error when Desktop effects activated.

Problem already existed in Fedora 10

Version-Release number of selected component (if applicable):

thunderbird-3.0-2.3.beta2.fc11.i586
firefox-3.5-0.20.beta4.fc11.i586
kmod-nvidia-2.6.29.4-167.fc11.i686.PAE-185.18.14-1.fc11.i686
xorg-x11-drv-nvidia-libs-185.18.14-2.fc11.i586
akmod-nvidia-185.18.14-1.fc11.i686
xorg-x11-drv-nvidia-185.18.14-2.fc11.i586

How reproducible:

This problem occurs randomly.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

$ thunderbird
The program 'thunderbird-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 1040 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Expected results:


Additional info:
Comment 1 Didier G 2009-06-19 08:03:24 EDT
To complete bug description :

I have two profiles so thunderbird start profilemanager first and bug happens after I choiced which profile I want to use

According Google it seems this problem occurs also with Debian/Ubuntu and is corrected for these distributions by package thunderbird-gnome-support
Comment 2 Matěj Cepl 2009-06-19 13:50:23 EDT
Thanks for the report. We are sorry that we cannot help you with your problem, but we are not able to support binary-only drivers. If you would be able to reproduce this issue using only open source software, please, reopen this bug with the additional information, but in meantime I have no choice than to close this bug as CANTFIX (because we really cannot fix it).

The open source 'nouveau' driver (in package xorg-x11-drv-nouveau) is the recommended alternative for users of Nvidia graphic chips.  It is used by default in Fedora 11 and later if you remove any customizations that explicitly set the video driver.  The older "nv" driver may be needed in some cases.  It is also available in older Fedora releases.  Install the packages xorg-x11-drv-nouveau or xorg-x11-drv-nv and override the X server's default choice if necessary.  See https://fedoraproject.org/wiki/Features/NouveauAsDefault for more information.

If you used a non-packaged version of the driver from the Nvidia website please clean your system from additional libraries and software it installed. For users who are experiencing problems installing, configuring, or using the unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides indirect customer support via an online web based support forum.  Nvidia monitors these web forums for commonly reported problems and passes them on to Nvidia engineers for investigation.  Once they've isolated a particular problem, it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

	http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have experienced the particular problem may be able to assist.  If there is a real bug occuring, Nvidia will be able to determine this, and will likely resolve the issue in a future driver update for the operating system releases that they officially support.

While we does not support the proprietary nvidia driver, users requiring technical support may also find the various X.Org, XFree86, and Red Hat/Fedora mailing lists helpful in finding assistance:

X.Org mailing lists:
	http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
	http://www.xfree86.org/sos/lists.html

Red Hat/Fedora mailing lists:
	https://listman.redhat.com/mailman/listinfo
Comment 3 Ola Thoresen 2009-10-24 13:38:05 EDT
The problem does not seem to be related to the Nvidia driver (at least not only that).
I have the same problem with both firefox and tunderbird from time to time, using the supplied "intel"-driver:

(II) LoadModule: "intel"
(II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
(II) Module intel: vendor="X.Org Foundation"
        compiled for 1.6.99.903, module version = 2.9.0
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0

Both firefox and thunderbird crash after the "select profile"-dialog

$ firefox
The program 'firefox' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 359 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

$ thunderbird 
The program 'thunderbird-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 527 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


Usually they will actually start after trying five-six-seven times.
It seems like it might help adding "--sync" as suggested by the error, but even with this parameter they crash with the same error a few times before actaully starting up.

Note You need to log in before you can comment on or make changes to this bug.