Bug 506940 - Quick Search should sort results by relevancy, not by bug number
Quick Search should sort results by relevancy, not by bug number
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.6
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 08:17 EDT by Michal Schmidt
Modified: 2013-06-23 22:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 19:58:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2009-06-19 08:17:33 EDT
Description of problem:
Quick Search (https://bugzilla.redhat.com/buglist.cgi?quicksearch=...) sorts the results by the bug number (ID). This often puts irrelevant bugs on top.

As an example try searching for "cannot commit to disk" which is an error message given by Anaconda in F11. Bugzilla finds 37 bugs, ranging from 170893 to 506930. The most relevant bug (bug 491754 titled "DeviceError: cannot commit to disk sda after 5 attempts") is near to the end of the list. Since it contains the exact phrase, I'd like to see it on top.

OTOH, if I use Google Search (https://bugzilla.redhat.com/query.cgi?format=google), it puts the most relevant bug correctly right on top.

Proposed solution:
Please consider making the Quick Search function use the Google Search (at least when no special features are used in the query (those documented in https://bugzilla.redhat.com/page.cgi?id=quicksearch.html)).
Comment 1 Noura El hawary 2009-06-19 08:51:37 EDT
Hi Michal,

If you click on the ID column label in the search result it should reverse the search for you. I hope this helps.

Noura
Comment 2 Michal Schmidt 2009-06-19 09:15:34 EDT
Noura,

thank you for the suggestion. Unfortunately, reversing the list is not a solution. It may help a bit in this specific case, where the most relevant bug was almost at the bottom, but generally it can be anywhere in the middle.
There needs to be a more clever algorithm to determine the relevancy of a search result (such as what the Google Search does).
Comment 3 David Lawrence 2010-01-15 11:55:35 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this bug will need to be re-verified against the new release. With
the updated code this bug may no longer be relevant or may have been fixed in
the new code. Updating bug version to 3.4.
Comment 4 David Lawrence 2010-08-25 17:43:44 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 5 Simon Green 2012-06-19 19:58:25 EDT
(In reply to comment #0)
> Proposed solution:
> Please consider making the Quick Search function use the Google Search (at
> least when no special features are used in the query (those documented in
> https://bugzilla.redhat.com/page.cgi?id=quicksearch.html)).

This isn't practical since (a) Google does not crawl the site in real time and (b) Google does not crawl private bugs.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.