Bug 50695 - ks fails to install lilo on system with scsi disc
Summary: ks fails to install lilo on system with scsi disc
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 50696 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-02 10:38 UTC by Gerald Teschl
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-02 15:32:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2001-08-02 10:38:54 UTC
I just did a ks/nfs installation on a scsi only system (one hd and one
cdrom). I used

lilo --location mbr 

in the ks.cfg file. The installation went fine but upon reboot of the
system the kernel will not be able to load the initial ram disk
(no initrd found at block) and then naturally fail to mount the
root device because of the missing scsi drive. I tried to install
again and this is 100% reproducible. Then I used the same ks.cfg
file on my laptop (ide only) and there were no problems.

Morover, booting the scsi box from cdrom, mounting the hardrive
and executing lilo, the box will be fine.

Comment 1 Gerald Teschl 2001-08-02 10:41:09 UTC
Just noticed I forgot a 0: "no initrd found at block 0"

Comment 2 Gerald Teschl 2001-08-02 10:42:12 UTC
*** Bug 50696 has been marked as a duplicate of this bug. ***

Comment 3 Gerald Teschl 2001-08-02 15:32:29 UTC
Maybe this is a problem with lilo and not with anaconda. See also #50718.

Comment 4 Jeremy Katz 2001-08-02 15:47:28 UTC
No, there was a problem with initrd creation and lilo, since fixed in cvs


Note You need to log in before you can comment on or make changes to this bug.