Bug 506974 - lsusb: cannot open "/usr/share/usb.ids", No such file or directory
lsusb: cannot open "/usr/share/usb.ids", No such file or directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: usbutils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-19 12:03 EDT by Nalin Dahyabhai
Modified: 2015-02-01 17:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-16 04:41:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
changes that worked for me (1.05 KB, patch)
2009-06-19 12:03 EDT, Nalin Dahyabhai
no flags Details | Diff

  None (edit)
Description Nalin Dahyabhai 2009-06-19 12:03:06 EDT
Created attachment 348681 [details]
changes that worked for me

Description of problem:
Since 0.82-1, I'm getting incomplete information from "lsusb".  It also complains when I run it:
  lsusb: cannot open "/usr/share/usb.ids", No such file or directory

Version-Release number of selected component (if applicable):
0.82-1.fc12.x86_64

How reproducible:
Always
Comment 1 John Ellson 2009-06-19 19:34:30 EDT
On fc10 lsusb used to read /usr/share/hwdata/usb.ids.  Now on rawhide the executable agrees with the man page, but either both are wrong, or hwdata-0.222-1.fc10.noarch installs /usr/share/hwdata/usb.ids in the wrong place.

A workaround is to:
    cd /usr/share
    ln -s hwdata/usb.ids
Comment 2 Jiri Moskovcak 2009-07-01 07:24:17 EDT
Thanks for the report, i fixed it in rawhide, if you want to test it here it is: http://koji.fedoraproject.org/koji/taskinfo?taskID=1446508
Comment 3 Jiri Moskovcak 2009-07-01 09:15:19 EDT
Second try: http://koji.fedoraproject.org/koji/taskinfo?taskID=1446828
Comment 4 Nalin Dahyabhai 2009-07-01 12:07:45 EDT
I installed usbutils-0.82-3.fc12.x86_64 and 'lsusb' appears to be working properly again.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.